
<!doctype html>
<html prefix="og: http://ogp.me/ns#" lang="en-gb" dir="ltr">
<head><meta charset="utf-8">
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-80147-10"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-80147-10');
</script>
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
<link rel="canonical" href="https://www.speedwaydigest.com/news/eracing-news/55813-richmond-invitational-race-report-kyle-busch-finishes-fifth-in-toyota-owners-150">
<base href="https://www.speedwaydigest.com/news/eracing-news/55813-richmond-invitational-race-report-kyle-busch-finishes-fifth-in-toyota-owners-150" />
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="keywords" content="NASCAR, NASCAR News, NASCAR Drivers, NASCAR Frequencies, Monster Cup, XFINITY, Camping World, NASCAR Points, Speedway Digest, Speedway Digest NASCAR News, Daytona, Richmond, Martinsville, Dover, Charlotte, Darlington, North Wilkesboro, Texas Motor Speedway, Pocono Speedway, Watkins Glen, Auto Club Speedway, Bristol Motor Speedway, Kansas Speedway, Talladega Superspeedway, Atlanta Motor Speedway, News, Jimmie Johnson, Roush Racing, Hendricks Motorsports, BK Racing, Wood Brothers Racing, Richard Petty Motorsports, Yates Racing, Robert Yates Racing, Michael Waltrip Racing, Carl Edwards, Trevor Bayne, Save The Speedway, North Wilkesboro Speedway, Dale Earnhardt, Dale Earnhardt Jr., NASCAR Frequencies, Monster Energy NASCAR Cup Series, Monster Energy Series, XFINITY Series, Camping World Truck Series, Las Vegas Motor Speedway, Phoenix International Raceway, Charlotte Motor Speedway, New Hampshire Motor Speedway, Gateway Motorsports Park, Darlington Raceway, Ryan Blaney, Chase Elliott, Ford Performance, Team Chevy, Toyota Racing, Kyle Busch, Kurt Busch, Denny Hamlin, NASCAR schedule, nascar race today, nascar race schedule, nascar race results, nascar race this weekend, nascar race results today, nascar truck race, nascar trucks, where is the nascar race today, nascar xfinity race, nascar schedule, nascar news, daytona 500, nascar race today, nascar today, nascar race, nascar results, nascar race schedule, nascar live" />
<meta name="rights" content="Copyright - Steven B. Wilson - STS Motorsports Inc. 2005 - 2019" />
<meta name="author" content="Speedway Digest Staff" />
<meta property="og:url" content="https://www.speedwaydigest.com/news/eracing-news/55813-richmond-invitational-race-report-kyle-busch-finishes-fifth-in-toyota-owners-150" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Richmond Invitational Race Report Kyle Busch Finishes Fifth in Toyota Owners 150" />
<meta property="og:description" content="Details: •Race: Toyota Owners 150 (Round 4) •Series: eNASCAR iRacing Pro Invitational Series •Date: Sunday, April 19 •Location: Virtual Richmond Raceway (.75-mile oval) •Distance: 150 laps (112.5 miles) •Result: Started 27th, Finished 5th (Running, completed 152 of 152 laps) •Winner: William Byron o..." />
<meta property="og:image" content="https://www.speedwaydigest.com/media/k2/items/cache/07ecc67f26d33a4ce414aaa1e5910ce7_M.jpg" />
<meta name="image" content="https://www.speedwaydigest.com/media/k2/items/cache/07ecc67f26d33a4ce414aaa1e5910ce7_M.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Richmond Invitational Race Report Kyle Busch Finishes Fifth in Toyota Owners 150" />
<meta name="twitter:description" content="Details: •Race: Toyota Owners 150 (Round 4) •Series: eNASCAR iRacing Pro Invitational Series •Date: Sunday, April 19 •Location: Virtual Richmond Raceway (.75-mile oval) •Distance: 150 laps (112.5 mile..." />
<meta name="twitter:image" content="https://www.speedwaydigest.com/media/k2/items/cache/07ecc67f26d33a4ce414aaa1e5910ce7_M.jpg" />
<meta name="twitter:image:alt" content="Richmond Invitational Race Report Kyle Busch Finishes Fifth in Toyota Owners 150" />
<meta name="description" content="Details: •Race: Toyota Owners 150 (Round 4) •Series: eNASCAR iRacing Pro Invitational Series •Date: Sunday, April 19 •Location: Virtual Richmond Racew..." />
<title>Richmond Invitational Race Report Kyle Busch Finishes Fifth in Toyota Owners 150</title>
<link href="/news/eracing-news/55813-richmond-invitational-race-report-kyle-busch-finishes-fifth-in-toyota-owners-150" rel="canonical" />
<link href="https://www.speedwaydigest.com/news/eracing-news/55813-richmond-invitational-race-report-kyle-busch-finishes-fifth-in-toyota-owners-150/amp" rel="amphtml" />
<link href="/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://cdn.jsdelivr.net/npm/magnific-popup@1.1.0/dist/magnific-popup.min.css" rel="stylesheet" type="text/css" />
<link href="https://cdn.jsdelivr.net/npm/simple-line-icons@2.4.1/css/simple-line-icons.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newslinen/css/k2.css?v=2.10.3" rel="stylesheet" type="text/css" />
<link href="/media/plg_content_osembed/css/osembed.css?b1e1275a19a606c2c7c810800746402a" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=PT+Serif:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&amp;display=swap&amp;subset=cyrillic-ext" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Roboto:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&amp;display=swap&amp;subset=cyrillic-ext" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Heebo:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&amp;display=swap&amp;subset=latin" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Heebo:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&amp;display=swap&amp;subset=hebrew" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newslinen/css/bootstrap.min.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newslinen/css/font-awesome.min.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newslinen/css/icofonts.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newslinen/css/owlcarousel.min.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newslinen/css/jquery.mCustomScrollbar.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newslinen/css/template.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newslinen/css/presets/preset1.css" rel="stylesheet" type="text/css" />
<link href="/modules/mod_sp_social/assets/css/default/sp_social.css" rel="stylesheet" type="text/css" />
<style type="text/css">

                        /* K2 - Magnific Popup Overrides */
                        .mfp-iframe-holder {padding:10px;}
                        .mfp-iframe-holder .mfp-content {max-width:100%;width:100%;height:100%;}
                        .mfp-iframe-scaler iframe {background:#fff;padding:10px;box-sizing:border-box;box-shadow:none;}
                    body.site {background-image: url(/images/bg1.jpg);background-repeat: repeat;background-size: cover;background-attachment: fixed;background-position: 0 0;}#sp-footer2 .sp-module ul > li {
border-bottom: 0 none;
padding: 0.3em;
display: inline;
float: top;
}body{font-family: 'PT Serif', sans-serif;font-size: 14px;font-weight: 400;font-style: normal;}
h1{font-family: 'Roboto', sans-serif;font-size: 30px;font-weight: 500;font-style: normal;}
h2{font-family: 'Roboto', sans-serif;font-size: 30px;font-weight: 500;}
h3{font-family: 'Roboto', sans-serif;font-size: 24px;font-weight: 500;}
h4{font-family: 'Roboto', sans-serif;font-size: 20px;font-weight: 500;font-style: normal;}
.sp-megamenu-parent > li > a, .sp-megamenu-parent > li > span, .sp-megamenu-parent .sp-dropdown li.sp-menu-item > a{font-family: 'Heebo', sans-serif;font-weight: 700;}
.nspInfo .nspCategory, .sppb-meta-category .nspCategory,
.ts-post-tab-list .sppb-nav-tabs li a,
.ts-bottom-social ul li a .ts-social-title,
.btn,
.sppb-meta-category a{font-family: 'Heebo', sans-serif;}
.logo-image {height:50px;}#sp-top-bar{ background-color:#2c2c2c;color:#ffffff;padding:4px 0px 4px 0px; }#sp-top-bar a{color:#ffffff;}#sp-logo-area{ background-color:#ffffff;padding:20px 15px 20px 20px;margin:0px 0px 0px 0px; }#sp-menu{ background-color:#2c2c2c;padding:0px; }#sp-main-body{ background-color:#ffffff; }#sp-footer{ background-color:#171717;color:#ffffff;padding:20px 0; }#sp-footer a{color:#ffffff;}
	</style>
<script src="/media/jui/js/jquery.min.js?a966be500c70802cfa089c646be7df3e" type="text/javascript"></script>
<script src="/media/jui/js/jquery-noconflict.js?a966be500c70802cfa089c646be7df3e" type="text/javascript"></script>
<script src="/media/jui/js/jquery-migrate.min.js?a966be500c70802cfa089c646be7df3e" type="text/javascript"></script>
<script src="https://cdn.jsdelivr.net/npm/magnific-popup@1.1.0/dist/jquery.magnific-popup.min.js" type="text/javascript"></script>
<script src="/media/k2/assets/js/k2.frontend.js?v=2.10.3&b=20191219&sitepath=/" type="text/javascript"></script>
<script src="/media/plg_content_osembed/js/osembed.js?b1e1275a19a606c2c7c810800746402a" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/popper.min.js" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/bootstrap.min.js" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/owl-carousel.2.3.0.min.js" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/jquery.mCustomScrollbar.concat.min.js" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/main.js" type="text/javascript"></script>
<script type="application/ld+json">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</script>
<script type="text/javascript">
template="ts_newslinen";
	</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-4983971213106691",
          enable_page_level_ads: true
     });
</script>
<script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>
<script async custom-element="amp-auto-ads" src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js">
</script>
<meta property="fb:pages" content="173396959362248" />
<script type="text/javascript">
var show_popup=1;
jQuery(document).bind("contextmenu", function(e) { if (show_popup==0) e.preventDefault(); else {e.preventDefault();jQuery('#openModal').css('opacity','1');jQuery('#openModal').css('pointer-events','auto');} });
jQuery(document).ready(function() {
    jQuery(document).on("click","#close",function() {
        jQuery('#openModal').css('opacity','0');
        jQuery('#openModal').css('pointer-events','none');
    });
});
</script><style type="text/css">
	.modalDialog {
	position: fixed;
	font-family: Arial, Helvetica, sans-serif;
	top: 0;
	right: 0;
	bottom: 0;
	left: 0;
	background: rgba(0,0,0,0.8);
	z-index: 99999;
	opacity:0;
	-webkit-transition: opacity 400ms ease-in;
	-moz-transition: opacity 400ms ease-in;
	transition: opacity 400ms ease-in;
pointer-events: none;
}

.modalDialog:target {
	opacity:1;
	pointer-events: auto;
}

.modalDialog > div {
	width: 400px;
	position: relative;
	margin: 10% auto;
	padding: 5px 20px 13px 20px;
	border-radius: 10px;
	background: #fff;
	background: -moz-linear-gradient(#fff, #999);
	background: -webkit-linear-gradient(#fff, #999);
	background: -o-linear-gradient(#fff, #999);
}

.close {
	background: #606061;
	color: #FFFFFF;
	line-height: 25px;
	position: absolute;
	right: -12px;
	text-align: center;
	top: -10px;
	width: 24px;
	text-decoration: none;
	font-weight: bold;
	-webkit-border-radius: 12px;
	-moz-border-radius: 12px;
	border-radius: 12px;
	-moz-box-shadow: 1px 1px 3px #000;
	-webkit-box-shadow: 1px 1px 3px #000;
	box-shadow: 1px 1px 3px #000;
}

.close:hover { background: #00d9ff; }
</style>
<script type="text/javascript">
	function disableSelection(target){
	if (typeof target.onselectstart!="undefined") // IE
		target.onselectstart=function(){return false}
	else if (typeof target.style.MozUserSelect!="undefined") // Firefox
		target.style.MozUserSelect="none"
	else // Opera etc
		target.onmousedown=function(){return false}
	target.style.cursor = "default"
	}
</script>
<script type="text/javascript">
		window.addEvent('domready', function() {
			document.body.oncopy = function() {
				return false;
			}
		});
</script>
<meta http-equiv="imagetoolbar" content="no">
<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 114431;
var ezdomain = 'speedwaydigest.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":114431,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"97e32b02-7f7c-4e02-7095-9c8f9b068e82","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":6926,"serverid":"3.80.140.29:7258","state":"VA","t_epoch":1587427446,"template_id":120,"time_on_site_visit":0,"url":"https://www.speedwaydigest.com/news/eracing-news/55813-richmond-invitational-race-report-kyle-busch-finishes-fifth-in-toyota-owners-150","user_id":0,"word_count":941,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_114431=" + new Date().getTime() + "|97e32b02-7f7c-4e02-7095-9c8f9b068e82|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>
<body class="site helix-ultimate com-k2 view-item layout-default task-none itemid-2153 en-gb ltr sticky-header layout-boxed offcanvas-init offcanvs-position-right">
<div class="body-wrapper">
<div class="body-innerwrapper">
<section id="sp-top-bar" class="ts-top-bar-classic d-none d-sm-none d-md-block"><div class="container"><div class="container-inner"><div class="row"><div id="sp-top1" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content">
<div id="ts_date155" class="ts_date_area ">
<i class="fa fa-clock-o"> </i>
Monday, Apr 20</div></div></div></div></div><div id="sp-top-menu" class="col-lg-3  d-md-none d-lg-block"><div class="sp-column "></div></div><div id="sp-top3" class="col-lg-7 "><div class="sp-column ts-top-social text-right"><ul class="social-icons"><li class="social-icon-facebook"><a ondragstart="return false;" target="_blank" href="https://www.facebook.com/speedwaydigest" aria-label="facebook"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a ondragstart="return false;" target="_blank" href="https://www.twitter.com/speedwaydigest" aria-label="twitter"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-pinterest"><a ondragstart="return false;" target="_blank" href="https://www.pinterest.com/speedwaydigest/" aria-label="Pinterest"><span class="fa fa-pinterest" aria-hidden="true"></span></a></li><li><a ondragstart="return false;" target="_blank" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A" aria-label="Youtube"><span class="fa fa-youtube" aria-hidden="true"></span></a></li></ul></div></div></div></div></div></section><section id="sp-logo-area"><div class="container"><div class="container-inner"><div class="row"><div id="sp-logo" class="col-md-4 col-lg-3 "><div class="sp-column "><div class="logo"><a ondragstart="return false;" href="/"><img ondragstart="return false;" class="logo-image d-none d-lg-inline-block" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"><img ondragstart="return false;" class="logo-image-phone d-inline-block d-lg-none" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"></a></div></div></div><div id="sp-top-banner-2" class="col-md-8 col-lg-9 d-none d-sm-none d-md-block"><div class="sp-column "><div class="sp-module "><div class="sp-module-content">
<div class="custom">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-4983971213106691" data-ad-slot="7293211960"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div></div></div></div></div></div></div></section><section id="sp-menu" class="ts-nav-box"><div class="container"><div class="container-inner"><div class="row"><div id="sp-menu" class="col-8 col-md-11 col-lg-11 "><div class="sp-column ts-menu"><nav class="sp-megamenu-wrapper" role="navigation"><a ondragstart="return false;" id="offcanvas-toggler" aria-label="Navigation" class="offcanvas-toggler-right d-block d-lg-none" href="#"><i class="fa fa-bars" aria-hidden="true" title="Navigation"></i></a><ul class="sp-megamenu-parent menu-animation-fade-up d-none d-lg-block"><li class="sp-menu-item"><a ondragstart="return false;" href="/">Home</a></li><li class="sp-menu-item sp-has-child active"><a ondragstart="return false;" href="/news">News</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/news/xfinity-series-news">Xfinity Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/news/speedway-news">Speedway News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/news/racing-news">Racing News</a></li><li class="sp-menu-item current-item active"><a ondragstart="return false;" href="/news/eracing-news">eRacing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/news/latest-news">Latest News</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/nascar-schedules">Schedules</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/point-standings">Point Standings</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/point-standings/xfinity-series">Xfinity Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/scanner-frequencies">Scanner Frequencies</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></div></div></li><li class="sp-menu-item"><a ondragstart="return false;" href="/writers-wanted">Writers Wanted</a></li></ul></nav></div></div><div id="sp-search" class="col-lg-1 "><div class="sp-column "><div class="sp-module  ts-search"><div class="sp-module-content">
<div class="nav-search-icon">
<i class="icon icon-search"></i>
</div>
<div class="nav-search-form" style="display: none;">
<div class="search ts-search">
<form action="/news/eracing-news" method="post">
<input name="searchword" id="mod-search-searchword" maxlength="200" class="inputbox search-query" type="text" size="0" placeholder="Type and hit ENTER" /><span class="search-close">×</span> <input type="hidden" name="task" value="search" />
<input type="hidden" name="option" value="com_search" />
<input type="hidden" name="Itemid" value="2153" />
</form>
</div>
</div></div></div></div></div></div></div></div></section><section id="sp-main-body"><div class="container"><div class="container-inner"><div class="row"><main id="sp-component" class="col-lg-8 " role="main"><div class="sp-column "><div id="system-message-container">
</div>

<span id="startOfPageId55813"></span>
<div id="k2Container" class="blog-details-content ts-content-box itemView">


<div class="itemHeader">

<h2 class="itemTitle">
Richmond Invitational Race Report Kyle Busch Finishes Fifth in Toyota Owners 150
</h2>
</div>
<div class="ItemMetaInfo">

<span class="itemAuthor">
<a ondragstart="return false;" rel="author" href="/news/eracing-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a>
</span>

<div class="itemCategory">
<a ondragstart="return false;" href="/news/eracing-news">eRacing News</a>
</div>

<span class="itemDateCreated">
<i class="fa fa-clock-o"></i> Sunday, Apr 19 </span>

<span class="itemHits">
<i class="icon-fire" aria-hidden="true"></i>
104 </span>
</div>


<div class="itemBody">



<div class="itemImageBlock">
<span class="itemImage">
<a ondragstart="return false;" data-k2-modal="image" href="/media/k2/items/cache/07ecc67f26d33a4ce414aaa1e5910ce7_XL.jpg" title="Click to preview image">
<img ondragstart="return false;" src="/media/k2/items/cache/07ecc67f26d33a4ce414aaa1e5910ce7_L.jpg" alt="Richmond Invitational Race Report Kyle Busch Finishes Fifth in Toyota Owners 150" style="width:400px; height:auto;" />
</a>
</span>
<div class="clr"></div>
</div>

<div class="itemFullText">
<div style="border-color: #c2d9e7;">
<table style="word-wrap: break-word; table-layout: fixed;" width="100%" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="background-color: #cacfd1; color: #000000; font-family: 'Trebuchet MS'; font-size: 11px; border: 0px none transparent; padding: 0px;" bgcolor="#cacfd1">
<p style="padding: 0; margin: 0;"><strong><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">Details:</span></span></strong></p>
</td>
</tr>
</tbody>
</table>
</div>
<div style="border-color: #c2d9e7;">
<table style="word-wrap: break-word; table-layout: fixed;" width="100%" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="color: #000000; font-family: 'Trebuchet MS'; font-size: 11px;">
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">•<strong>Ra</strong></span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><strong>ce: </strong>Toyota Owners 150 (Round 4)</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">•</span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><strong>Series: </strong>eNASCAR iRacing Pro Invitational Series</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">•</span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><strong>Date: </strong>Sunday, April 19</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">•</span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><strong>Location: </strong>Virtual Richmond Raceway (.75-mile oval)</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">•</span><strong><span style="font-family: tahoma, geneva, sans-serif;"><span style="font-size: 13px;">Distance:</span></span> </strong><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">150 laps (112.5 miles)</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">•</span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><strong>Result: </strong>Started 27th, Finished 5th (Running, completed 152 of 152 laps)</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">•</span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><strong>Winner: </strong>William Byron of Hendrick Motorsports</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">•</span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><strong>Note: </strong>Race extended four laps past its scheduled 150-lap distance due to a green-white- checkered finish.</span></span></p>
<p style="padding: 0; margin: 0;"> </p>
</td>
</tr>
</tbody>
</table>
</div>
<div style="border-color: #c2d9e7;">
<table style="word-wrap: break-word; table-layout: fixed;" width="100%" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="background-color: #cacfd1; color: #000000; font-family: 'Trebuchet MS'; font-size: 11px; border: 0px none transparent; padding: 0px;" bgcolor="#cacfd1">
<p style="padding: 0; margin: 0;"><strong><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">Kyle Busch, Driver of the No. 18 M&amp;M'S Toyota Camry:</span></span></strong></p>
</td>
</tr>
</tbody>
</table>
</div>
<div style="border-color: #c2d9e7;">
<table style="word-wrap: break-word; table-layout: fixed;" width="100%" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="color: #000000; font-family: 'Trebuchet MS'; font-size: 11px;">
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><strong><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">You drove from the back of the field to the front again this week. How were you able to get up there and stay there for your first top-five in the Pro Invitational Series?</span></span></strong></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">“At the start I thought here we go, it’s Groundhog day with qualifying. We don’t have very good qualifying efforts, but once we get going into the race, you can kind of methodically, slowly pick you way off and get yourself more up to the front and run with those top guys. It would be nice to figure out qualifying and start up front and see if we have a shot to race inside the top three all day and race for the win. I’ve just been working hard at getting a little bit more and more out of our M&amp;M’s Camry and trying to figure out some more iRacing tricks.”</span></span></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><strong><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">Later in the race you took two tires instead of four. If you had taken four, do you think you could have gotten back up to the front?</span></span></strong></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">“I don’t think four tires was getting you through the field as good as it should have. Brad (Keselowski) behind us had four tires on and he caught up to us from a little further back, but there was not much he could do once he got there. I think two was the right choice, but then if we would have had four for the very final restart I think that would have been better off with our strategy, but we had to get the track position earlier in the day to be in that position for later.”</span></span></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><strong>Does it feel good to bring home a top-five finish?</strong></span></span></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">“It does feel good to get a top-five. We’re just having fun out there and trying to do what we can and try to put on a good show for the fans watching on tv. It’s been interesting, that’s for sure. I’ve been trying to get better at this thing and pick it up. I don’t know what else there is to do for qualifying. I’m out of ideas, so if anyone has any idea what to do then let me know.”</span></span></p>
<p style="padding: 0; margin: 0;"> </p>
</td>
</tr>
</tbody>
</table>
</div>
<div style="border-color: #c2d9e7;">
<table style="word-wrap: break-word; table-layout: fixed;" width="100%" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="background-color: #cacfd1; color: #000000; font-family: 'Trebuchet MS'; font-size: 11px; border: 0px none transparent; padding: 0px;" bgcolor="#cacfd1">
<p style="padding: 0; margin: 0;"><strong><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">Notes:</span></span></strong></p>
</td>
</tr>
</tbody>
</table>
</div>
<div style="border-color: #c2d9e7;">
<table style="word-wrap: break-word; table-layout: fixed;" width="100%" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="color: #000000; font-family: 'Trebuchet MS'; font-size: 11px;">
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">• </span><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">This was Busch’s fourth appearance in the eNASCAR iRacing Pro Invitational Series.</span></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">• </span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">Busch’s fifth-place finish at virtual Richmond topped his previous best finish of 17th from the second race of the series at virtual Texas.  </span></span></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">• </span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">The eNASCAR iRacing Pro Invitational Series is an exhibition esports series featuring a collection of past and present racecar drivers from the NASCAR Cup Series.</span></span></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">• </span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">The eNASCAR iRacing Pro Invitational Series is a multi-week series emulating the original 2020 NASCAR Cup Series schedule.</span></span></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">• </span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">With the sports world on a necessary hiatus to combat the spread of the coronavirus, the eNASCAR iRacing Pro Invitational Series exists in place of actual NASCAR events.</span></span></p>
<p style="padding: 0; margin: 0;"> </p>
</td>
</tr>
</tbody>
</table>
</div>
<div style="border-color: #c2d9e7;">
<table style="word-wrap: break-word; table-layout: fixed;" width="100%" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="background-color: #cacfd1; color: #000000; font-family: 'Trebuchet MS'; font-size: 11px; border: 0px none transparent; padding: 0px;" bgcolor="#cacfd1">
<p style="padding: 0; margin: 0;"><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><strong>Next Up &amp; Where to Watch:</strong></span></span></p>
</td>
</tr>
</tbody>
</table>
</div>
<div style="border-color: #c2d9e7;">
<table style="word-wrap: break-word; table-layout: fixed;" width="100%" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="color: #000000; font-family: 'Trebuchet MS'; font-size: 11px;">
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;">The next event on the eNASCAR iRacing Pro Invitational Series schedule is Sunday, April 26 at the virtual Talladega Superspeedway. The race starts at 1 p.m. EDT with live coverage via…</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">•  </span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"><a ondragstart="return false;" style="color: #0000ff;" href="https://click.icptrack.com/icp/relay.php?r=15282472&amp;msgid=168111&amp;act=CHQ9&amp;c=1568606&amp;destination=https%3A%2F%2Fwww.fox.com%2Fsports%2F&amp;cf=7205&amp;v=7f7e8b3ce63c58cab878d1f4bdc6626123a9da7c4abbd6d3a81d3f377e37fe2b" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://click.icptrack.com/icp/relay.php?r%3D15282472%26msgid%3D168111%26act%3DCHQ9%26c%3D1568606%26destination%3Dhttps%253A%252F%252Fwww.fox.com%252Fsports%252F%26cf%3D7205%26v%3D7f7e8b3ce63c58cab878d1f4bdc6626123a9da7c4abbd6d3a81d3f377e37fe2b&amp;source=gmail&amp;ust=1587412940361000&amp;usg=AFQjCNERJ3r8ZzUfbv2cESPqboE3ux7GGA">FOX</a> network</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">• </span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"> <a ondragstart="return false;" style="color: #0000ff;" href="https://click.icptrack.com/icp/relay.php?r=15282472&amp;msgid=168111&amp;act=CHQ9&amp;c=1568606&amp;destination=https%3A%2F%2Fwww.foxsports.com%2Ffind-fs1-on-your-tv&amp;cf=7205&amp;v=117a93f839482248c3cf342d2b6e1f8e9239226d1b9986dd4b70e1cb6d671a1a" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://click.icptrack.com/icp/relay.php?r%3D15282472%26msgid%3D168111%26act%3DCHQ9%26c%3D1568606%26destination%3Dhttps%253A%252F%252Fwww.foxsports.com%252Ffind-fs1-on-your-tv%26cf%3D7205%26v%3D117a93f839482248c3cf342d2b6e1f8e9239226d1b9986dd4b70e1cb6d671a1a&amp;source=gmail&amp;ust=1587412940361000&amp;usg=AFQjCNGPXmAcSMOwXn5eOV4zXXA5gl11MQ">FS1</a> (DIRECTV Channel 219 and Dish Channel 150)</span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">• </span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"> <a ondragstart="return false;" style="color: #0000ff;" href="https://click.icptrack.com/icp/relay.php?r=15282472&amp;msgid=168111&amp;act=CHQ9&amp;c=1568606&amp;destination=https%3A%2F%2Fwww.foxsportsgo.com%2F&amp;cf=7205&amp;v=30a3edbdfed51abf69e6c3367fdb9f0b19fc856f5e8fe9a3cf87ef5aaa6c16ee" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://click.icptrack.com/icp/relay.php?r%3D15282472%26msgid%3D168111%26act%3DCHQ9%26c%3D1568606%26destination%3Dhttps%253A%252F%252Fwww.foxsportsgo.com%252F%26cf%3D7205%26v%3D30a3edbdfed51abf69e6c3367fdb9f0b19fc856f5e8fe9a3cf87ef5aaa6c16ee&amp;source=gmail&amp;ust=1587412940361000&amp;usg=AFQjCNG-SetuHDlO73cPc0ihBZjfV_oFPQ">FOX Sports app</a></span></span></p>
<p style="padding: 0; margin: 0;"><span style="font-family: tahoma,geneva,sans-serif; font-size: 13px;">• </span><span style="font-size: 13px;"><span style="font-family: tahoma,geneva,sans-serif;"> <a ondragstart="return false;" style="color: #0000ff;" href="https://click.icptrack.com/icp/relay.php?r=15282472&amp;msgid=168111&amp;act=CHQ9&amp;c=1568606&amp;destination=https%3A%2F%2Fwww.foxsports.com%2Fmotor%2Ffox-sports-racing&amp;cf=7205&amp;v=68a177347e21dd6cb0d1ab1e545808233b343509425866feb05127ba7ece9bd5" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://click.icptrack.com/icp/relay.php?r%3D15282472%26msgid%3D168111%26act%3DCHQ9%26c%3D1568606%26destination%3Dhttps%253A%252F%252Fwww.foxsports.com%252Fmotor%252Ffox-sports-racing%26cf%3D7205%26v%3D68a177347e21dd6cb0d1ab1e545808233b343509425866feb05127ba7ece9bd5&amp;source=gmail&amp;ust=1587412940362000&amp;usg=AFQjCNFHFxGDpPcGjba4jf88_nT5LUh-ug">FOX Sports Racing</a> for fans in Canada</span></span></p>
<p style="padding: 0; margin: 0;"> </p>
<p style="padding: 0; margin: 0;"><span style="font-size: 13px;">TSC PR</span></p>
</td>
</tr>
</tbody>
</table>
</div> </div>
<div class="clr"></div>
<div class="itemToolbarContent">

<div class="itemRatingBlock">
<span>Rate this item</span>
<div class="itemRatingForm">
<ul class="itemRatingList">
<li class="itemCurrentRating" id="itemCurrentRating55813" style="width:0%;"></li>
<li><a ondragstart="return false;" href="#" data-id="55813" title="1 star out of 5" class="one-star">1</a></li>
<li><a ondragstart="return false;" href="#" data-id="55813" title="2 stars out of 5" class="two-stars">2</a></li>
<li><a ondragstart="return false;" href="#" data-id="55813" title="3 stars out of 5" class="three-stars">3</a></li>
<li><a ondragstart="return false;" href="#" data-id="55813" title="4 stars out of 5" class="four-stars">4</a></li>
<li><a ondragstart="return false;" href="#" data-id="55813" title="5 stars out of 5" class="five-stars">5</a></li>
</ul>
<div id="itemRatingLog55813" class="itemRatingLog">(0 votes)</div>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>
<div class="itemToolbar float-right">
<ul>

<li>
<span class="itemTextResizerTitle">font size</span>
<a ondragstart="return false;" href="#" id="fontDecrease">
<span>decrease font size</span>
</a>
<a ondragstart="return false;" href="#" id="fontIncrease">
<span>increase font size</span>
</a>
</li>

<li>
<a ondragstart="return false;" class="itemPrintLink" rel="nofollow" href="/news/eracing-news/55813-richmond-invitational-race-report-kyle-busch-finishes-fifth-in-toyota-owners-150?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;">
<span>Print</span>
</a>
</li>

<li>
<a ondragstart="return false;" class="itemEmailLink" rel="nofollow" href="/component/mailto/?tmpl=component&amp;template=ts_newslinen&amp;link=a2c25466515404c9b1d29dd9372fbf9128e3b348" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;">
<span>Email</span>
</a>
</li>
</ul>
<div class="clr"></div>
</div>
</div>
<div class="itemContentFooter">
<div class="clr"></div>
</div>


<div class="clr"></div>
</div>

<div class="itemSocialSharing">

<div class="itemTwitterButton">
<a ondragstart="return false;" href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>

<div class="itemFacebookButton">
<div id="fb-root"></div>
<script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)) return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script>
<div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
</div>
<div class="clr"></div>
</div>
<div class="itemLinks">
<div class="clr"></div>
</div>

<div class="itemNavigation">
<a ondragstart="return false;" class="itemPrevious" href="/news/eracing-news/55812-william-byron-takes-the-win-at-virtual-richmond-raceway">&laquo; William Byron takes the win at virtual Richmond Raceway</a>
<a ondragstart="return false;" class="itemNext" href="/news/eracing-news/55814-william-byron-wins-toyota-owners-150-enascar-iracing-pro-invitational-series-race-at-virtual-richmond-raceway">William Byron Wins Toyota Owners 150 eNASCAR iRacing Pro Invitational Series Race at Virtual Richmond Raceway &raquo;</a>
</div>

<div class="itemAuthorBlock">
<img ondragstart="return false;" class="itemAuthorAvatar" src="/media/k2/users/13.png" alt="Speedway Digest Staff" />
<div class="itemAuthorDetails">
<h3 class="itemAuthorName">
<a ondragstart="return false;" rel="author" href="/news/eracing-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a>
</h3>
<p><p>Follow us on Twitter <a ondragstart="return false;" href="https://www.twitter.com/speedwaydigest">@SpeedwayDigest</a></p></p>
<div class="clr"></div>

<div class="clr"></div>
</div>
<div class="clr"></div>
</div>

<div class="itemAuthorLatest">
<h3>Latest from Speedway Digest Staff</h3>
<ul>
 <li class="even">
<a ondragstart="return false;" href="/news/speedway-news/55817-add-indianapolis-500-to-your-virtual-meeting-background-today">Add Indianapolis 500 To Your Virtual Meeting Background Today</a>
</li>
<li class="odd">
<a ondragstart="return false;" href="/news/speedway-news/55816-texas-motor-speedway-statement-regarding-texas-governor-abbott-comments">Texas Motor Speedway statement regarding Texas Governor Abbott comments</a>
</li>
<li class="even">
<a ondragstart="return false;" href="/news/racing-news/55815-horses-and-horsepower-premiere-on-ride-tv">Horses and Horsepower premiere on RIDE TV</a>
</li>
<li class="odd">
<a ondragstart="return false;" href="/news/eracing-news/55814-william-byron-wins-toyota-owners-150-enascar-iracing-pro-invitational-series-race-at-virtual-richmond-raceway">William Byron Wins Toyota Owners 150 eNASCAR iRacing Pro Invitational Series Race at Virtual Richmond Raceway</a>
</li>
<li class="even">
<a ondragstart="return false;" href="/news/eracing-news/55812-william-byron-takes-the-win-at-virtual-richmond-raceway">William Byron takes the win at virtual Richmond Raceway</a>
</li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>


<div class="itemBackToTop">
<a ondragstart="return false;" class="k2Anchor" href="/news/eracing-news/55813-richmond-invitational-race-report-kyle-busch-finishes-fifth-in-toyota-owners-150#startOfPageId55813">
back to top </a>
</div>
<div class="clr"></div>
</div>


</div></main><aside id="sp-right" class="col-lg-4 "><div class="sp-column "><div class="sp-module  ts-block-social-list title-bg"><h3 class="sp-module-title">Follow Us</h3><div class="sp-module-content">
<div id="sp_social205" class="sp_social icon_size_32  ts-block-social-list title-bg">
<ul>
<li class="rss">
<a ondragstart="return false;" target='_blank' title="RSS" href="https://speedwaydigest.com/index.php/news/latest-news?format=feed"><i class="fa fa-rss"></i>
<span class="ts-social-title">RSS</span>
<span class="ts-social-desc">Subscribe us on News</span></a></li>
</a></li>
<li class="facebook"><a ondragstart="return false;" target='_blank' title="Facebook" href="https://www.facebook.com/speedwaydigest"><i class="fa fa-facebook"> </i>
<span class="ts-social-title">Facebook</span>
<span class="ts-social-desc">Like us on Facebook</span></a></li>
<li class="twitter"><a ondragstart="return false;" target='_blank' title="Twitter" href="https://www.twitter.com/speedwaydigest"><i class="fa fa-twitter"></i>
<span class="ts-social-title">Twitter</span>
<span class="ts-social-desc">Follow us on Twitter</span></a></li>
<li class="youtube"><a ondragstart="return false;" target='_blank' title="YouTube" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A"><i class="fa fa-youtube"></i>
<span class="ts-social-title">Youtube</span>
<span class="ts-social-desc">Subscribe on Youtube</span></a></li>
</a></li>
</ul>
<div style="clear:both"></div>
</div></div></div><div class="sp-module "><div class="sp-module-content">
<div class="custom">
<center> <ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 250px;" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1975255967"></ins></center></div>
</div></div><div class="sp-module "><div class="sp-module-content">
<div class="custom">
<center> <ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 250px;" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1975255967"></ins></center></div>
</div></div></div></aside></div></div></div></section><footer id="sp-footer" class="ts-footer"><div class="row"><div id="sp-footer1" class="col-lg-6 "><div class="sp-column text-center"><span class="sp-copyright">Copyright © 2010 - 2020 STS Motorsports Inc. All Rights Reserved.</span></div></div><div id="sp-footer2" class="col-lg-6 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><ul class="menu nav-pills">
<li class="item-1557"><a ondragstart="return false;" href="/advertise">Advertise</a></li><li class="item-1559"><a ondragstart="return false;" href="/privacy-policy">Privacy Policy</a></li><li class="item-1621"><a ondragstart="return false;" href="/sitemap">Sitemap</a></li><li class="item-1558"><a ondragstart="return false;" href="/sd-staff">SD Staff</a></li><li class="item-1576"><a ondragstart="return false;" href="/writer-login">Writer Login</a></li></ul>
</div></div></div></div></div></footer> </div>
</div>

<div class="offcanvas-overlay"></div>
<div class="offcanvas-menu">
<a ondragstart="return false;" href="#" class="close-offcanvas"><span class="fa fa-remove"></span></a>
<div class="offcanvas-inner">
<div class="sp-module "><div class="sp-module-content"><ul class="menu">
<li class="item-241 default"><a ondragstart="return false;" href="/">Home</a></li><li class="item-186 active menu-deeper menu-parent"><a ondragstart="return false;" href="/news">News<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-205"><a ondragstart="return false;" href="/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="item-188"><a ondragstart="return false;" href="/news/xfinity-series-news">Xfinity Series News</a></li><li class="item-1922"><a ondragstart="return false;" href="/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="item-190"><a ondragstart="return false;" href="/news/speedway-news">Speedway News</a></li><li class="item-207"><a ondragstart="return false;" href="/news/racing-news">Racing News</a></li><li class="item-2153 current active"><a ondragstart="return false;" href="/news/eracing-news">eRacing News</a></li><li class="item-1876"><a ondragstart="return false;" href="/news/latest-news">Latest News</a></li></ul></li><li class="item-197 menu-deeper menu-parent"><a ondragstart="return false;" href="/nascar-schedules">Schedules<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-198"><a ondragstart="return false;" href="/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="item-199"><a ondragstart="return false;" href="/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="item-200"><a ondragstart="return false;" href="/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="item-202"><a ondragstart="return false;" href="/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></li><li class="item-208 menu-deeper menu-parent"><a ondragstart="return false;" href="/point-standings">Point Standings<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-209"><a ondragstart="return false;" href="/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="item-210"><a ondragstart="return false;" href="/point-standings/xfinity-series">Xfinity Series</a></li><li class="item-211"><a ondragstart="return false;" href="/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></li><li class="item-204 menu-deeper menu-parent"><a ondragstart="return false;" href="/scanner-frequencies">Scanner Frequencies<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-235"><a ondragstart="return false;" href="/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="item-236"><a ondragstart="return false;" href="/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="item-237"><a ondragstart="return false;" href="/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="item-1596"><a ondragstart="return false;" href="/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></li><li class="item-606"><a ondragstart="return false;" href="/writers-wanted">Writers Wanted</a></li></ul>
</div></div>
</div>
</div>

<a ondragstart="return false;" href="#" class="sp-scroll-up" aria-label="Scroll Up"><span class="fa fa-chevron-up" aria-hidden="true"></span></a>

<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-DLpLH67QrYURU"
});
</script>
<noscript>
<div style="display:none;">
<img ondragstart="return false;" src="//pixel.quantserve.com/pixel/p-DLpLH67QrYURU.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>

<div id="openModal" class="modalDialog">
<div>
<a ondragstart="return false;" href="#close" title="Close" id="close" class="close">X</a>
<h2>No right click</h2>
<p>Please link the article. </p>
</div>
</div>
<script type="text/javascript">
	disableSelection(document.body)
</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>
<script>var _audins_dom="speedwaydigest_com",_audins_did=114431;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.speedwaydigest_com,DomainId.114431" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(a){for(var b=0;b<document.styleSheets.length;b++)if(document.styleSheets[b].href==a)return!0;return!1}var a=function(a,b){for(var d=0;d<b.length;d++){var c=b[d];if(0==c.complete||"undefined"!=typeof c.readyState&&4>c.readyState){var g=c.getAttribute("src")||c.currentSrc;"undefined"!=typeof c.readyState&&0==c.readyState?c.addEventListener("loadstart",function(a){var b=a.getAttribute("src")||a.currentSrc;window.ezorqs(a,b)}):(g=c.getAttribute("src")||c.currentSrc,window.ezorqs(c,
	g));c.addEventListener("load",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)});c.addEventListener("loadeddata",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)});c.addEventListener("error",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)})}}};a("img",document.querySelectorAll("img"));a("video",document.querySelectorAll("video"));a("audio",document.querySelectorAll("audio"));
	(function(a){for(var c=0;c<a.length;c++){var d=a[c];if(("preload"==d.getAttribute("rel")||"stylesheet"==d.getAttribute("rel"))&&null!=d.getAttribute("href")&&b(d.getAttribute("href"))){window.ezorqs(d,d.getAttribute("href"));var e=document.createElement("img");e.onerror=function(a){"undefined"!=typeof a.path&&"undefined"!=typeof a.path[0].currentSrc?window.ezorqe(d,a.path[0].currentSrc):"undefined"!=typeof a.srcElement&&"undefined"!=typeof a.srcElement.href&&window.ezorqe(d,a.srcElement.href)};e.src=
	d.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script><script type="text/javascript" onload="__ezcl.handle(true);" async src="/utilcave_com/inc/ezcl.webp?cb=4"></script></body>
</html>