<!doctype html><html prefix="og: http://ogp.me/ns#" lang="en-gb" dir="ltr"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="canonical" href="https://www.speedwaydigest.com/index.php/news/racing-news/64591-euronascar-set-for-another-amazing-race-weekend-at-autodrom-most"><base href="https://www.speedwaydigest.com/index.php/news/racing-news/64591-euronascar-set-for-another-amazing-race-weekend-at-autodrom-most" /><meta http-equiv="content-type" content="text/html; charset=utf-8" /><meta name="keywords" content="NASCAR, NASCAR News, NASCAR Drivers, NASCAR Frequencies, NASCAR Cup Series, Monster Cup, XFINITY, Xfinity Series, Camping World, Camping World Truck Series, NASCAR Points, Speedway Digest, Speedway Digest NASCAR News, Daytona, Richmond, Martinsville, Dover, Charlotte, Darlington, North Wilkesboro, Texas Motor Speedway, Pocono Speedway, Watkins Glen, Auto Club Speedway, Bristol Motor Speedway, Kansas Speedway, Talladega Superspeedway, Atlanta Motor Speedway, News, Jimmie Johnson, Roush Racing, Hendricks Motorsports, BK Racing, Wood Brothers Racing, Richard Petty Motorsports, Yates Racing, Robert Yates Racing, Michael Waltrip Racing, Carl Edwards, Trevor Bayne, Save The Speedway, North Wilkesboro Speedway, Dale Earnhardt, Dale Earnhardt Jr., NASCAR Frequencies, Monster Energy NASCAR Cup Series, Monster Energy Series, XFINITY Series, Camping World Truck Series, Las Vegas Motor Speedway, Phoenix International Raceway, Charlotte Motor Speedway, New Hampshire Motor Speedway, Gateway Motorsports Park, Darlington Raceway, Ryan Blaney, Chase Elliott, Ford Performance, Team Chevy, Toyota Racing, Kyle Busch, Kurt Busch, Denny Hamlin, NASCAR schedule, nascar race today, nascar race schedule, nascar race results, nascar race this weekend, nascar race results today, nascar truck race, nascar trucks, where is the nascar race today, nascar xfinity race, nascar schedule, nascar news, daytona 500, nascar race today, nascar today, nascar race, nascar results, nascar race schedule, nascar live, race scanner, racing scanner, race scanners" /><meta name="rights" content="Copyright - Steven B. Wilson - STS Motorsports Inc. 2005 - 2021" /><meta name="author" content="Speedway Digest Staff" /><meta property="og:url" content="https://www.speedwaydigest.com/index.php/news/racing-news/64591-euronascar-set-for-another-amazing-race-weekend-at-autodrom-most?utm_source=dlvr.it&amp;utm_medium=twitter" /><meta property="og:type" content="article" /><meta property="og:title" content="EuroNASCAR set for another amazing race weekend at Autodrom Most" /><meta property="og:description" content="After a forced break in the 2020 NASCAR Whelen Euro Series season, the EuroNASCAR V8 beasts are finally back in the Czech Republic! The Autodrom Most will host the third event of the 2021 NWES season and mark the halfway point of the EuroNASCAR PRO and EuroNASCAR 2 Championships. In addition, the Cl..." /><meta property="og:image" content="https://www.speedwaydigest.com/media/k2/items/cache/01c09d2c6305f5de723587de4c3fb3bb_M.jpg" /><meta name="image" content="https://www.speedwaydigest.com/media/k2/items/cache/01c09d2c6305f5de723587de4c3fb3bb_M.jpg" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="EuroNASCAR set for another amazing race weekend at Autodrom Most" /><meta name="twitter:description" content="After a forced break in the 2020 NASCAR Whelen Euro Series season, the EuroNASCAR V8 beasts are finally back in the Czech Republic! The Autodrom Most will host the third event of the 2021 NWES season..." /><meta name="twitter:image" content="https://www.speedwaydigest.com/media/k2/items/cache/01c09d2c6305f5de723587de4c3fb3bb_M.jpg" /><meta name="twitter:image:alt" content="EuroNASCAR set for another amazing race weekend at Autodrom Most" /><meta name="description" content="After a forced break in the 2020 NASCAR Whelen Euro Series season, the EuroNASCAR V8 beasts are finally back in the Czech Republic! The Autodrom Most..." /><meta name="generator" content="Helix Ultimate - The Most Popular Joomla! Template Framework." /><title>EuroNASCAR set for another amazing race weekend at Autodrom Most</title><link href="/index.php/news/racing-news/64591-euronascar-set-for-another-amazing-race-weekend-at-autodrom-most" rel="canonical" /><link href="https://www.speedwaydigest.com/index.php/news/racing-news/64591-euronascar-set-for-another-amazing-race-weekend-at-autodrom-most/amp" rel="amphtml" /><link href="/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /><link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /> <script type="application/json" class="joomla-script-options new">{"data":{"breakpoints":{"tablet":991,"mobile":480},"header":{"stickyOffset":"100"}},"csrf.token":"c5c5bba8ad157da1836a9adcc569c29a","system.paths":{"root":"","base":""}}</script> <script type="application/ld+json">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</script><meta http-equiv="imagetoolbar" content="no"><style type="text/css">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</style><link rel="preload" href="/media/plg_jchoptimize/cache/css/e9253766db4fd4c693351a6cc868abd8.css" as="style" onload="this.onload=null;this.rel='stylesheet'" /><noscript><link rel="stylesheet" href="/media/plg_jchoptimize/cache/css/e9253766db4fd4c693351a6cc868abd8.css" /></noscript><script>(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){};}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload");}catch(e){ret=false;}
return function(){return ret;};})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener){link.removeEventListener("load",enableStylesheet);}else if(link.attachEvent){link.detachEvent("onload",enableStylesheet);}
link.setAttribute("onload",null);link.media=finalMedia;}
if(link.addEventListener){link.addEventListener("load",enableStylesheet);}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet);}
setTimeout(function(){link.rel="stylesheet";link.media="only x";});setTimeout(enableStylesheet,3000);};rp.poly=function(){if(rp.support()){return;}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",true);rp.bindMediaToggle(link);}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run);});}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run);});}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS;}
else{w.loadCSS=loadCSS;}}(typeof global!=="undefined"?global:this));</script> <script type="application/javascript" src="/media/plg_jchoptimize/cache/js/16a8541ab6fed9fe39c6f6c5c2215b92.js"></script> <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <script type="application/javascript" src="/media/plg_jchoptimize/cache/js/47b64f4681f55f169bf792b8258de0f1.js"></script><noscript><style type="text/css">img.jch-lazyload,iframe.jch-lazyload{display:none}</style> </noscript> </head><body class="site helix-ultimate hu com-k2 view-item layout-default task-none itemid-207 en-gb ltr sticky-header layout-boxed offcanvas-init offcanvs-position-right"><div class="body-wrapper"><div class="body-innerwrapper"><section id="sp-top-bar" class="ts-top-bar-classic d-none d-sm-none d-md-block"><div class="container"><div class="container-inner"><div class="row"><div id="sp-top1" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div id="ts_date155" class="ts_date_area "> <i class="fa fa-calendar-check-o"> </i> Thursday, Aug 26</div></div></div></div></div><div id="sp-top-menu" class="col-lg-3  d-md-none d-lg-block"><div class="sp-column "></div></div><div id="sp-top3" class="col-lg-7 "><div class="sp-column ts-top-social text-right"><ul class="social-icons"><li class="social-icon-facebook"><a ondragstart="return false;" target="_blank" href="https://www.facebook.com/speedwaydigest" aria-label="facebook"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a ondragstart="return false;" target="_blank" href="https://www.twitter.com/speedwaydigest" aria-label="twitter"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-pinterest"><a ondragstart="return false;" target="_blank" href="https://www.pinterest.com/speedwaydigest/" aria-label="Pinterest"><span class="fa fa-pinterest" aria-hidden="true"></span></a></li><li><a ondragstart="return false;" target="_blank" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A" aria-label="Youtube"><span class="fa fa-youtube" aria-hidden="true"></span></a></li></ul></div></div></div></div></div></section><section id="sp-logo-area"><div class="container"><div class="container-inner"><div class="row"><div id="sp-logo" class="col-md-4 col-lg-12 "><div class="sp-column "><div class="logo"><a ondragstart="return false;" href="/"><img ondragstart="return false;" class="logo-image d-none d-lg-inline-block" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"><img ondragstart="return false;" class="logo-image-phone d-inline-block d-lg-none" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"></a></div></div></div></div></div></div></section><section id="sp-menu" class="ts-nav-box"><div class="container"><div class="container-inner"><div class="row"><div id="sp-menu" class="col-8 col-md-11 col-lg-11 "><div class="sp-column ts-menu"><nav class="sp-megamenu-wrapper" role="navigation"><a ondragstart="return false;" id="offcanvas-toggler" aria-label="Navigation" class="offcanvas-toggler-right d-block d-lg-none" href="#"><i class="fa fa-bars" aria-hidden="true" title="Navigation"></i></a><ul class="sp-megamenu-parent menu-animation-fade-up d-none d-lg-block"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="sp-menu-item sp-has-child active"><a ondragstart="return false;" href="/index.php/news">News</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="sp-menu-item current-item active"><a ondragstart="return false;" aria-current="page" href="/index.php/news/racing-news">Racing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></div></div></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></nav></div></div><div id="sp-search" class="col-lg-1 "><div class="sp-column "><div class="sp-module  ts-search"><div class="sp-module-content"><div class="nav-search-icon"> <i class="icon icon-search"></i> </div><div class="nav-search-form" style="display: none;"><div class="search ts-search"><form action="/index.php/news/racing-news" method="post"> <input name="searchword" id="mod-search-searchword" maxlength="200" class="inputbox search-query" type="text" size="0" placeholder="Type and hit ENTER" /><span class="search-close">×</span> <input type="hidden" name="task" value="search" /> <input type="hidden" name="option" value="com_search" /> <input type="hidden" name="Itemid" value="207" /> </form></div></div></div></div></div></div></div></div></div></section><section id="sp-main-body"><div class="container"><div class="container-inner"><div class="row"> <main id="sp-component" class="col-lg-8 "><div class="sp-column "><div id="system-message-container"> </div> <span id="startOfPageId64591"></span> <div id="k2Container" class="blog-details-content ts-content-box itemView"><div class="itemHeader"><h2 class="itemTitle"> EuroNASCAR set for another amazing race weekend at Autodrom Most </h2></div><div class="ItemMetaInfo"> <span class="itemAuthor"> <a ondragstart="return false;" rel="author" href="/index.php/news/racing-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </span> <div class="itemCategory"> <a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a> </div> <span class="itemDateCreated"> <i class="fa fa-clock-o"></i> Thursday, Aug 26 </span> <span class="itemHits"> <i class="icon-fire" aria-hidden="true"></i> 27 </span> </div><div class="itemBody"><div class="itemImageBlock"> <span class="itemImage"> <a ondragstart="return false;" data-k2-modal="image" href="/media/k2/items/cache/01c09d2c6305f5de723587de4c3fb3bb_XL.jpg" title="Click to preview image"> <img class="jch-lazyload" ondragstart="return false;" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/items/cache/01c09d2c6305f5de723587de4c3fb3bb_L.jpg" alt="EuroNASCAR set for another amazing race weekend at Autodrom Most" style="width:400px; height:auto;" /><noscript><img ondragstart="return false;" src="/media/k2/items/cache/01c09d2c6305f5de723587de4c3fb3bb_L.jpg" alt="EuroNASCAR set for another amazing race weekend at Autodrom Most" style="width:400px; height:auto;" /></noscript></a> </span> <div class="clr"></div></div><div class="itemFullText"><p>After a forced break in the 2020 NASCAR Whelen Euro Series season, the EuroNASCAR V8 beasts are finally back in the Czech Republic! The Autodrom Most will host the third event of the 2021 NWES season and mark the halfway point of the EuroNASCAR PRO and EuroNASCAR 2 Championships. In addition, the Club Challenge will be back in action on Friday morning. The championship battles are on and who’s gonna leave the Czech Republic as the points leader with the red Whelen banner?<br /> <br /> <strong>EuroNASCAR PRO: Hezemans the man to beat</strong><br /> <br /> Loris Hezemans leads the EuroNASCAR PRO standings after four races between Valencia and Brands Hatch. The Dutchman, who’s piloting the #50 Hendriks Motorsport Ford Mustang, scored three wins and a second place so far. That puts him in the lead with a 20 point advantage on CAAL Racing’s Gianmarco Ercoli. Reigning Champion and CAAL Racing returnee Alon Day has to show his comeback qualities as he sits only in eighth despite having won Round 3  at Brands Hatch.<br /> <br /> Hezemans has mixed memories of the Autodrom Most: the Dutchman suffered a blown engine in the first race of 2019 but came back with a remarkable win on Sunday. Day on the other side speaks of the “worst memory of his racing career” when he thinks about the first NASCAR GP Czech Republic. The Israeli had to retire in both races back in 2019 and therefore has a score to settle. Ercoli’s best finish at Autodrom Most so far is a seventh place in the Saturday race of 2019.<br /> <br /> But there is also a strong title contender named Nicolo Rocca: In 2019, the Italian won the first race at Autodrom Most that put him right in the title battle for the season. In 2021, Rocca is third in the overall standings with a 25-point deficit on Hezemans. The Turin native wants to confirm his strong form at Autodrom Most with two solid results and maybe his first win with DF1 Racing. With EuroNASCAR 2 Champion Vittorio Ghirelli and the “Flying Dutchman” Sebastiaan Bleekemolen lurking in fourth and fifth, there are two more hot candidates for the first EuroNASCAR PRO wins of their careers.<br /> <br /> NWES veterans Lucas Lasserre and Frederic Gabillon follow in sixth and seventh. Both Frenchmen are also eager to add another win to their records, while Giorgio Maggi, who’s tied with Day in eighth, wants to bring his brand new designed #18 Ford Mustang with the colors of Switzerland into Victory Lane. Marc Goossens is tenth in the overall standings and also hungry to climb the ranks.<br /> <br /> <strong>EuroNASCAR 2: Tobias Dauenhauer versus the local hero?</strong><br /> <br /> 2020 runner-up Tobias Dauenhauer is leading the EuroNASCAR 2 Championship after scoring his first win of the season at Brands Hatch. The German Hendriks Motorsport driver sits 9 points ahead of Most’s local hero Martin Doubek, who dominated the season opener at Circuit Ricardo Tormo in Valencia with two wins. Will the German and the Czech be battling for the overall lead or will there be a surprise winner like Advait Deodhar in the UK?<br /> <br /> One of those possible first time winners could be Vladimiros Tziortis at the wheel of the #1 Academy Motorsport / Alex Caffi Motorsport Ford Mustang. With three top-5 and four top-10 results so far, the Cypriot is only 15 points shy of the Championship leader. Brands Hatch winner Deodhar follows in fourth with a 20-point deficit. Double V Racing’s Pierluigi Veronesi is fifth, only 1 point behind the Indian in the CAAL Racing colors.<br /> <br /> Israel’s Naveh Talor is another dark horse for the NASCAR GP Czech Republic. The Not Only Motorsport driver shone with one top-5 and three top-10 results so far and is eager to score his first EuroNASCAR 2 win. Simon Pilate and Alberto Panebianco will make their Most debuts at the upcoming weekend, while Justin Kunz from Germany has scored one top-5 and two top-10’s at Most in the 2019 season. Youngster Francesco Garisto rounds out the top-10 of the overall standings.<br /> <br /> The NASCAR GP Czech Republic at Autodrom Most takes place on August 28-29. Qualifying and all races will be broadcasted live on the EuroNASCAR social media platforms – YouTube, NWES App, Facebook and Twitch – as well as on Motorsport.tv.<br /> <br /> <strong>EuroNASCAR PRO</strong><br /> <br /> <strong>Alon Day wants to finish his first race at Most</strong> – After retiring in both races of the 2019 NWES season, the Israeli wants to see the checkered flag for the first time at Autodrom Most in a EuroNASCAR car. With two strong results, the CAAL Racing driver could get back right into the championship battle to defend his title.<br /> <br /> <strong>The Trophy battles are on fire </strong>– While Gianmarco Ercoli dominates the Junior Trophy for drivers of an age of a maximum of 25 ahead of Giorgio Maggi, the top-4 of the Challenger Trophy for bronze and silver drivers in EuroNASCAR are only separated by 9 points. Marko Stipp Motorsport’s Yevgen Sokolovskiy leads the special classification.<br /> <br /> <strong>Jacques Villeneuve back on the grid</strong> – The 1997 Formula One World Champion had to skip the NASCAR GP UK due to his obligations on TV. The Canadian will be back on the grid at Autodrom Most with Academy Motorsport / Alex Caffi Motorsport.<br /> <br /> <strong>EuroNASCAR 2</strong><br /> <br /> <strong>Alberto Panebianco the rookie to beat </strong>– The Italian has a strong advantage in the Rookie Trophy standings after four solid runs at Valencia and Brands Hatch. The Not Only Motorsport driver leads the special classification ahead of Miguel Gomes and Alina Loibnegger.<br /> <br /> <strong>2 points separate the Legend Trophy top drivers</strong> – Yevgen Sokolovskiy and Max Lanza are only 2 points apart in the Legend Trophy for drivers aged 40 and more. Ian Eric Waden follows in third with a small 10-point deficit on the special classification’s leader from the Ukraine. In the Lady Trophy, Arianna Casoli leads Loibnegger by 5 points.<br /> <br /> <strong>A new track for several top drivers</strong> – Due to its cancellation in the 2020 NWES season, a lot of top drivers of the EuroNASCAR 2 Championship will get to know Most for the first time. Dauenhauer, Tziortzis, Pilate and Garisto are among the debutants in EuroNASCAR. Deodhar, Veronesi, Talor and Kunz, on the other hand, already have important experience on the 4.1 kilometer long track.</p><p>NWES PR</p></div><div class="clr"></div><div class="itemToolbarContent"><div class="itemRatingBlock"> <span>Rate this item</span> <div class="itemRatingForm"><ul class="itemRatingList"> <li class="itemCurrentRating" id="itemCurrentRating64591" style="width:0%;"></li> <li><a ondragstart="return false;" href="#" data-id="64591" title="1 star out of 5" class="one-star">1</a></li> <li><a ondragstart="return false;" href="#" data-id="64591" title="2 stars out of 5" class="two-stars">2</a></li> <li><a ondragstart="return false;" href="#" data-id="64591" title="3 stars out of 5" class="three-stars">3</a></li> <li><a ondragstart="return false;" href="#" data-id="64591" title="4 stars out of 5" class="four-stars">4</a></li> <li><a ondragstart="return false;" href="#" data-id="64591" title="5 stars out of 5" class="five-stars">5</a></li> </ul><div id="itemRatingLog64591" class="itemRatingLog">(0 votes)</div><div class="clr"></div></div><div class="clr"></div></div><div class="itemToolbar float-right"><ul> <li> <span class="itemTextResizerTitle">font size</span> <a ondragstart="return false;" href="#" id="fontDecrease"> <span>decrease font size</span> </a> <a ondragstart="return false;" href="#" id="fontIncrease"> <span>increase font size</span> </a> </li> <li> <a ondragstart="return false;" class="itemPrintLink" rel="nofollow" href="/index.php/news/racing-news/64591-euronascar-set-for-another-amazing-race-weekend-at-autodrom-most?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;"> <span>Print</span> </a> </li> <li> <a ondragstart="return false;" class="itemEmailLink" rel="nofollow" href="/index.php/component/mailto/?tmpl=component&amp;template=ts_newslinen&amp;link=5866130bce294c2e0ffb7b8fbb378805cfda2dd8" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;"> <span>Email</span> </a> </li> </ul><div class="clr"></div></div></div><div class="itemContentFooter"><div class="clr"></div></div><div class="clr"></div></div><div class="itemSocialSharing"><div class="itemTwitterButton"> <a ondragstart="return false;" href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="">Tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','twitter-wjs');</script> </div><div class="itemFacebookButton"><div id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script><div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div></div><div class="clr"></div></div><div class="itemLinks"><div class="clr"></div></div><div class="itemNavigation"> <a ondragstart="return false;" class="itemPrevious" href="/index.php/news/racing-news/64583-parker-retzlaff-returns-to-arca-menards-series-east-competition-at-milwaukee-mile">&laquo; Parker Retzlaff returns to ARCA Menards Series East competition at Milwaukee Mile</a> </div><div class="itemAuthorBlock"> <img ondragstart="return false;" class="itemAuthorAvatar jch-lazyload" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/users/13.png" alt="Speedway Digest Staff" /><noscript><img ondragstart="return false;" class="itemAuthorAvatar" src="/media/k2/users/13.png" alt="Speedway Digest Staff" /></noscript><div class="itemAuthorDetails"><h3 class="itemAuthorName"> <a ondragstart="return false;" rel="author" href="/index.php/news/racing-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </h3><p><p>Follow us on Twitter <a ondragstart="return false;" href="https://www.twitter.com/speedwaydigest">@SpeedwayDigest</a></p></p><div class="clr"></div><div class="clr"></div></div><div class="clr"></div></div><div class="itemAuthorLatest"><h3>Latest from Speedway Digest Staff</h3><ul> <li class="even"> <a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news/64594-solid-start-teams-up-with-smithley-rwr-to-support-national-breast-cancer-foundation">Solid Start Teams Up with Smithley & RWR to Support National Breast Cancer Foundation</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/xfinity-series-news/64593-dylan-lupton-joins-forces-with-sam-hunt-racing-for-two-races">Dylan Lupton Joins Forces with Sam Hunt Racing for Two Races</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/speedway-news/64590-kids-take-center-stage-at-stafford-speedway-s-back-2-skool-night">Kids Take Center Stage at Stafford Speedway's Back 2 SKool Night</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/speedway-news/64589-official-commemorative-digital-souvenir-program-forbass-pro-shops-nra-night-race-available-to-fans-in-free-digital-download-starting-sept-10">Official Commemorative Digital Souvenir Program Forbass Pro Shops NRA Night Race Available to Fans in Free Digital Download Starting Sept. 10</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/xfinity-series-news/64588-peopleready-teams-up-with-jr-motorsports-sam-mayer-for-nascar-xfinity-series-wawa-250-race">PeopleReady teams up with JR Motorsports' Sam Mayer for NASCAR Xfinity Series Wawa 250 Race</a> </li> </ul><div class="clr"></div></div><div class="clr"></div><div class="itemBackToTop"> <a ondragstart="return false;" class="k2Anchor" href="/index.php/news/racing-news/64591-euronascar-set-for-another-amazing-race-weekend-at-autodrom-most#startOfPageId64591"> back to top </a> </div><div class="clr"></div></div></div></main><aside id="sp-right" class="col-lg-4 "><div class="sp-column "></div></aside></div></div></div></section><footer id="sp-footer" class="ts-footer"><div class="row"><div id="sp-footer1" class="col-lg-6 "><div class="sp-column text-center"><span class="sp-copyright">Copyright © 2010 - 2021 STS Motorsports Inc. All Rights Reserved.</span></div></div><div id="sp-footer2" class="col-lg-6 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><ul class="menu nav-pills"> <li class="item-1557"><a ondragstart="return false;" href="/index.php/advertise">Advertise</a></li><li class="item-1559"><a ondragstart="return false;" href="/index.php/privacy-policy">Privacy Policy</a></li><li class="item-1621"><a ondragstart="return false;" href="/index.php/sitemap">Sitemap</a></li><li class="item-1558"><a ondragstart="return false;" href="/index.php/sd-staff">SD Staff</a></li><li class="item-1576"><a ondragstart="return false;" href="/index.php/writer-login">Writer Login</a></li></ul></div></div></div></div></div></footer></div></div><div class="offcanvas-overlay"></div><div class="offcanvas-menu"> <a ondragstart="return false;" href="#" class="close-offcanvas"><span class="fa fa-remove"></span></a> <div class="offcanvas-inner"><div class="sp-module "><div class="sp-module-content"><ul class="menu"> <li class="item-241 default"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="item-186 active menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/news">News<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-205"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="item-188"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="item-1922"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="item-190"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="item-207 current active"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="item-2153"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="item-1876"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></li><li class="item-197 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-198"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="item-199"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="item-200"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="item-202"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></li><li class="item-208 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-209"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="item-210"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="item-211"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></li><li class="item-204 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-235"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="item-236"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="item-237"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="item-1596"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></li><li class="item-606"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></div></div></div></div> <a ondragstart="return false;" href="#" class="sp-scroll-up" aria-label="Scroll Up"><span class="fa fa-chevron-up" aria-hidden="true"></span></a> <amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-auto-format="rspv" data-full-width=""><div overflow=""></div></amp-ad><div id="openModal" class="modalDialog"><div> <a ondragstart="return false;" href="#close" title="Close" id="close" class="close">X</a> <h2>No right click</h2><p>Please link the article. </p></div></div> <script type="text/javascript">disableSelection(document.body)</script> </body> </html>