<!doctype html><html prefix="og: http://ogp.me/ns#" lang="en-gb" dir="ltr"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="canonical" href="https://www.speedwaydigest.com/index.php/news/nascar-truck-series-news/70486-nascar-national-series-news-notes-knoxville-raceway"><base href="https://www.speedwaydigest.com/index.php/news/nascar-truck-series-news/70486-nascar-national-series-news-notes-knoxville-raceway" /><meta http-equiv="content-type" content="text/html; charset=utf-8" /><meta name="keywords" content="NASCAR, NASCAR News, NASCAR Drivers, NASCAR Frequencies, NASCAR Cup Series, Monster Cup, XFINITY, Xfinity Series, Camping World, Camping World Truck Series, NASCAR Points, Speedway Digest, Speedway Digest NASCAR News, Daytona, Richmond, Martinsville, Dover, Charlotte, Darlington, North Wilkesboro, Texas Motor Speedway, Pocono Speedway, Watkins Glen, Auto Club Speedway, Bristol Motor Speedway, Kansas Speedway, Talladega Superspeedway, Atlanta Motor Speedway, News, Jimmie Johnson, Roush Racing, Hendricks Motorsports, BK Racing, Wood Brothers Racing, Richard Petty Motorsports, Yates Racing, Robert Yates Racing, Michael Waltrip Racing, Carl Edwards, Trevor Bayne, Save The Speedway, North Wilkesboro Speedway, Dale Earnhardt, Dale Earnhardt Jr., NASCAR Frequencies, Monster Energy NASCAR Cup Series, Monster Energy Series, XFINITY Series, Camping World Truck Series, Las Vegas Motor Speedway, Phoenix International Raceway, Charlotte Motor Speedway, New Hampshire Motor Speedway, Gateway Motorsports Park, Darlington Raceway, Ryan Blaney, Chase Elliott, Ford Performance, Team Chevy, Toyota Racing, Kyle Busch, Kurt Busch, Denny Hamlin, NASCAR schedule, nascar race today, nascar race schedule, nascar race results, nascar race this weekend, nascar race results today, nascar truck race, nascar trucks, where is the nascar race today, nascar xfinity race, nascar schedule, nascar news, daytona 500, nascar race today, nascar today, nascar race, nascar results, nascar race schedule, nascar live, race scanner, racing scanner, race scanners" /><meta name="rights" content="Copyright - Steven B. Wilson - STS Motorsports Inc. 2005 - 2022" /><meta name="author" content="Speedway Digest Staff" /><meta property="og:url" content="https://www.speedwaydigest.com/index.php/news/nascar-truck-series-news/70486-nascar-national-series-news-notes-knoxville-raceway" /><meta property="og:type" content="article" /><meta property="og:title" content="NASCAR National Series News &amp; Notes - Knoxville Raceway" /><meta property="og:description" content="NASCAR Cup Series Next Race: Ally 400 The Place: Nashville Superspeedway The Date: Sunday, June 26 The Time: 5 p.m. ET The Purse: $8,065,125 TV: NBC, 4:30 p.m. ET Radio: MRN, SiriusXM NASCAR Radio Distance: 399 miles (300 Laps); Stage 1 (Ends on Lap 90), Stage 2 (Ends on Lap 185), Final Stage (Ends..." /><meta property="og:image" content="https://www.speedwaydigest.com/media/k2/items/cache/ac4f3a096145293344a42879a0edef63_M.jpg" /><meta name="image" content="https://www.speedwaydigest.com/media/k2/items/cache/ac4f3a096145293344a42879a0edef63_M.jpg" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="NASCAR National Series News &amp; Notes - Knoxville Raceway" /><meta name="twitter:description" content="NASCAR Cup Series Next Race: Ally 400 The Place: Nashville Superspeedway The Date: Sunday, June 26 The Time: 5 p.m. ET The Purse: $8,065,125 TV: NBC, 4:30 p.m. ET Radio: MRN, SiriusXM NASCAR Radio Dis..." /><meta name="twitter:image" content="https://www.speedwaydigest.com/media/k2/items/cache/ac4f3a096145293344a42879a0edef63_M.jpg" /><meta name="twitter:image:alt" content="NASCAR National Series News &amp;amp; Notes - Knoxville Raceway" /><meta name="description" content="NASCAR Cup Series Next Race: Ally 400 The Place: Nashville Superspeedway The Date: Sunday, June 26 The Time: 5 p.m. ET The Purse: $8,065,125 TV: NBC,..." /><meta name="generator" content="HELIX_ULTIMATE_GENERATOR_TEXT" /><title>NASCAR National Series News &amp; Notes - Knoxville Raceway</title><link href="/index.php/news/nascar-truck-series-news/70486-nascar-national-series-news-notes-knoxville-raceway" rel="canonical" /><link href="https://www.speedwaydigest.com/index.php/news/nascar-truck-series-news/70486-nascar-national-series-news-notes-knoxville-raceway/amp" rel="amphtml" /><link href="/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /><link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /> <script type="application/json" class="joomla-script-options new">{"data":{"breakpoints":{"tablet":991,"mobile":480},"header":{"stickyOffset":"100"}},"csrf.token":"9741fa350a0f317b1ba7c28e5465a2de","system.paths":{"root":"","base":""}}</script> <script type="application/ld+json">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</script><meta http-equiv="imagetoolbar" content="no"><style id="jch-optimize-critical-css">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</style><link rel="preload" href="/media/com_jchoptimize/cache/css/27abc72238cae863a0102962fc782f99fcf199a7185d4548eb5e12a892a28df4.css" as="style" onload="rel='stylesheet'" /> <script src="/media/com_jchoptimize/cache/js/27abc72238cae863a0102962fc782f991ec57ee13067bd29350118d867d8ac46.js"></script> <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <script src="/media/com_jchoptimize/cache/js/27abc72238cae863a0102962fc782f995bf3899462652c65e8dc6876cf2ee56e.js"></script> <script src="/media/com_jchoptimize/cache/js/27abc72238cae863a0102962fc782f99d1e5c37ba8c991f5b6c31bf00d8ca03d.js" async></script> </head><body class="site helix-ultimate hu com-k2 view-item layout-default task-none itemid-1922 en-gb ltr sticky-header layout-boxed offcanvas-init offcanvs-position-right"><div class="body-wrapper"><div class="body-innerwrapper"><section id="sp-top-bar" class="ts-top-bar-classic d-none d-sm-none d-md-block"><div class="container"><div class="container-inner"><div class="row"><div id="sp-top1" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div id="ts_date155" class="ts_date_area "> <i class="fa fa-calendar-check-o"> </i> Friday, Jun 17</div></div></div></div></div><div id="sp-top-menu" class="col-lg-3  d-md-none d-lg-block"><div class="sp-column "></div></div><div id="sp-top3" class="col-lg-7 "><div class="sp-column ts-top-social text-right"><ul class="social-icons"><li class="social-icon-facebook"><a ondragstart="return false;" target="_blank" href="https://www.facebook.com/speedwaydigest" aria-label="facebook"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a ondragstart="return false;" target="_blank" href="https://www.twitter.com/speedwaydigest" aria-label="twitter"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-pinterest"><a ondragstart="return false;" target="_blank" href="https://www.pinterest.com/speedwaydigest/" aria-label="Pinterest"><span class="fa fa-pinterest" aria-hidden="true"></span></a></li><li><a ondragstart="return false;" target="_blank" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A" aria-label="Youtube"><span class="fa fa-youtube" aria-hidden="true"></span></a></li></ul></div></div></div></div></div></section><section id="sp-logo-area"><div class="container"><div class="container-inner"><div class="row"><div id="sp-logo" class="col-md-4 col-lg-3 "><div class="sp-column "><div class="logo"><a ondragstart="return false;" href="/"><img ondragstart="return false;" class="logo-image d-none d-lg-inline-block" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"><img ondragstart="return false;" class="logo-image-phone d-inline-block d-lg-none" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"></a></div></div></div><div id="sp-top-banner-2" class="col-md-8 col-lg-9 d-none d-sm-none d-md-block"><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="7293211960" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></div></div></div></div></div></div></section><section id="sp-menu" class="ts-nav-box"><div class="container"><div class="container-inner"><div class="row"><div id="sp-menu" class="col-8 col-md-11 col-lg-11 "><div class="sp-column ts-menu"><nav class="sp-megamenu-wrapper" role="navigation"><a ondragstart="return false;" id="offcanvas-toggler" aria-label="Navigation" class="offcanvas-toggler-right d-block d-lg-none" href="#"><i class="fa fa-bars" aria-hidden="true" title="Navigation"></i></a><ul class="sp-megamenu-parent menu-animation-fade-up d-none d-lg-block"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="sp-menu-item sp-has-child active"><a ondragstart="return false;" href="/index.php/news">News</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="sp-menu-item current-item active"><a ondragstart="return false;" aria-current="page" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></div></div></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></nav></div></div><div id="sp-search" class="col-lg-1 "><div class="sp-column "><div class="sp-module  ts-search"><div class="sp-module-content"><div class="nav-search-icon"> <i class="icon icon-search"></i> </div><div class="nav-search-form" style="display: none;"><div class="search ts-search"><form action="/index.php/news/nascar-truck-series-news" method="post"> <input name="searchword" id="mod-search-searchword" maxlength="200" class="inputbox search-query" type="text" size="0" placeholder="Type and hit ENTER" /><span class="search-close">×</span> <input type="hidden" name="task" value="search" /> <input type="hidden" name="option" value="com_search" /> <input type="hidden" name="Itemid" value="1922" /> </form></div></div></div></div></div></div></div></div></div></section><section id="sp-main-body"><div class="container"><div class="container-inner"><div class="row"> <main id="sp-component" class="col-lg-8 "><div class="sp-column "><div id="system-message-container"> </div> <span id="startOfPageId70486"></span> <div id="k2Container" class="blog-details-content ts-content-box itemView"><div class="itemHeader"><h2 class="itemTitle"> NASCAR National Series News &amp; Notes - Knoxville Raceway </h2></div><div class="ItemMetaInfo"> <span class="itemAuthor"> <a ondragstart="return false;" rel="author" href="/index.php/news/nascar-truck-series-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </span> <div class="itemCategory"> <a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a> </div> <span class="itemDateCreated"> <i class="fa fa-clock-o"></i> Wednesday, Jun 15 </span> <span class="itemHits"> <i class="icon-fire" aria-hidden="true"></i> 152 </span> </div><div class="itemBody"><div class="itemImageBlock"> <span class="itemImage"> <a ondragstart="return false;" data-k2-modal="image" href="/media/k2/items/cache/ac4f3a096145293344a42879a0edef63_XL.jpg" title="Click to preview image"> <img class="jch-lazyload" ondragstart="return false;" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/items/cache/ac4f3a096145293344a42879a0edef63_L.jpg" alt="NASCAR National Series News &amp;amp; Notes - Knoxville Raceway" style="width:400px; height:auto;" /><noscript><img ondragstart="return false;" src="/media/k2/items/cache/ac4f3a096145293344a42879a0edef63_L.jpg" alt="NASCAR National Series News &amp;amp; Notes - Knoxville Raceway" style="width:400px; height:auto;" /></noscript></a> </span> <div class="clr"></div></div><div class="itemFullText"><p><strong><u>NASCAR Cup Series</u></strong></p><p><strong>Next Race: Ally 400</strong></p><p><strong>The Place: Nashville Superspeedway</strong></p><p><strong>The Date: Sunday, June 26</strong></p><p><strong>The Time: 5 p.m. ET</strong></p><p><strong>The Purse: $8,065,125</strong></p><p><strong>TV: NBC, 4:30 p.m. ET</strong></p><p><strong>Radio: MRN, SiriusXM NASCAR Radio</strong></p><p><strong>Distance: 399 miles (300 Laps); Stage 1 (Ends on Lap 90),</strong></p><p><strong>Stage 2 (Ends on Lap 185), Final Stage (Ends on Lap 300)</strong></p><p><strong><u> </u></strong></p><p><strong><u>NASCAR Xfinity Series</u></strong></p><p><strong>Next Race: Tennessee Lottery 250</strong></p><p><strong>The Place: Nashville Superspeedway</strong></p><p><strong>The Date: Saturday, June 25</strong></p><p><strong>The Time: 3:30 p.m. ET</strong></p><p><strong>The Purse: $1,319,713</strong></p><p><strong>TV: USA, 3 p.m. ET</strong></p><p><strong>Radio: MRN, SiriusXM NASCAR Radio</strong></p><p><strong>Distance: 250.04 miles (188 Laps); Stage 1 (Ends on Lap 45),</strong></p><p><strong>Stage 2 (Ends on Lap 90), Final Stage (Ends on Lap 188)</strong></p><p><strong><u> </u></strong></p><p><strong><u>NASCAR Camping World Truck Series</u></strong></p><p><strong>Next Race: Clean Harbors 150</strong></p><p><strong>The Place: Knoxville Raceway</strong></p><p><strong>The Date: Saturday, June 18</strong></p><p><strong>The Time: 9 p.m. ET</strong></p><p><strong>The Purse: $629,075</strong></p><p><strong>TV: FS1, 8 p.m. ET</strong></p><p><strong>Radio: MRN, SiriusXM NASCAR Radio</strong></p><p><strong>Distance: 75 miles (150 Laps); Stage 1 (Ends on Lap 40),</strong></p><p><strong>Stage 2 (Ends on Lap 90), Final Stage (Ends on Lap 150)</strong></p><p><strong><u> </u></strong></p><p><strong><u>NASCAR Cup Series</u></strong></p><p> </p><p><strong>Daniel Suárez becomes 12th different NASCAR Cup Series winner of 2022</strong></p><p>Count ‘em up!</p><p> </p><p>A dozen different drivers have visited Victory Lane this season in the NASCAR Cup Series; tying the 2000 and 2012 seasons for second-most winners through 16 races in the Modern Era (1972-2022); behind only the 2003 season with 13 different winners.</p><p> </p><p>Since inception of the Playoffs in 2004, the most different winners the NASCAR Cup Series has seen during the 26-race regular season was 15 different winners in 2011. Currently, the 2022 season has produced the most different winners (12) through the first 16 races of any Playoff Era season (2004-2022), and with 10 races left in the regular season, 2022 could be the first to reach 16 or more different winners heading into the postseason.</p><p> </p><p>Trackhouse Racing’s Daniel Suárez became the 12th different NASCAR Cup Series winner this season with his victory last weekend at Sonoma Raceway. He also became the first driver from Mexico to win a NASCAR Cup Series race and the fifth different foreign-born driver to win a NASCAR Cup Series race; joining Marcos Ambrose (Australia), Juan Pablo Montoya (Colombia), Earl Ross (Canada) and Mario Andretti (Italy).</p><p> </p><p>Suárez also became the fourth different driver this season to win his first career NASCAR Cup Series event; joining Team Penske’s Austin Cindric (Daytona 500), Stewart-Haas Racing’s Chase Briscoe (Phoenix) and his Trackhouse Racing teammate Ross Chastain (COTA). The record in the Modern Era (1972-2022) for the most first-time Cup Series winners in a single season is five first-time winners and it has happened three times – 2001, 2002 and 2011.</p><p> </p><p>The NASCAR Cup Series will be back on-track next week at Nashville Superspeedway for the Ally 400 on June 26, 2022 at 5 p.m. ET on NBC, MRN and SiriusXM NASCAR Radio, the 17th race on the 2022 schedule. Hendrick Motorsport’s driver and 2021 series champion, Kyle Larson, is the defending Cup Series winner at Nashville Superspeedway.</p><p> </p><p><strong>Trackhouse Racing is one of the hottest new teams in the series</strong></p><p>Well, it didn’t take long for Justin Marks’ vision to take the NASCAR Cup Series by storm, and in Trackhouse Racing’s short two-year history, the organization has risen to be a leading competitor in the #1 form of motorsports competition in the United States – the NASCAR Cup Series.</p><p> </p><p>“What I said first and foremost is I believe with this new car (Next Gen) it's truly going to be about the people, and the people are going to make this car go,” said Justin Marks following Trackhouse Racing’s third victory of the 2022 season. “The way they (NASCAR) changed the model of the sport a little bit, is you have to invest in your people and keep them motivated, and put talented people in positions, lift them up and empower them. I just believe that.”</p><p> </p><p>A feat many have tried, and few have been able to accomplish so quickly, but co-owners Justin Marks and rapper/entertainer Pitbull have won three of the 16 NASCAR Cup Series races this season; tied for second-most by an organization this year in the series behind Hendrick Motorsports’ five wins. And to boot, both of their drivers, Ross Chastain (COTA, Talladega) and Daniel Suárez (Sonoma), have visited Victory Lane this season and have clicked their tickets to the Playoffs, another first for the new team.</p><p> </p><p>In addition to Suárez’s win this year, he has put up three top fives, five top 10s and has led 203 laps.</p><p> </p><p>Suarez’s teammate Ross Chastain has been running exceptionally well also this season amassing two wins (COTA, Talladega), seven top fives and 10 top 10s. </p><p> </p><p>Don’t expect Trackhouse Racing to slow any at Nashville Superspeedway next week. Ross Chastain finished runner-up in last season’s Nashville race and Suárez finished seventh.</p><p> </p><p><strong>Playoff Bubble: Four spots left open, 10 races to go</strong></p><p>With Daniel Suárez becoming the 12th different driver to win this season and earn a spot in the Playoffs, that leaves just four positions open in the 16-driver NASCAR Cup Series postseason field with 10 races left to go in the regular season. </p><p> </p><p>The four drivers currently in the Playoff hot seats that all drivers outside the postseason cutoff are coveting are Ryan Blaney (+95 points from the Playoff cutoff), Martin Truex Jr. (+65), Christopher Bell (+28) and Aric Almirola (+7).</p><p> </p><p>Stewart-Haas Racing’s Aric Almirola is currently in the most precarious position of the four drivers inside the Playoff cutoff, because he is in the 16th and final transfer position on points. But if a driver below him in the standings wins over the next 10 races, he could find himself bounced out of the Playoffs. Almirola currently has a seven-point advantage on his SHR teammate Kevin Harvick who is 17th - the first spot outside the Playoffs cutoff.</p><p> </p><p>Of the drivers looking for their first NASCAR Cup Series win of the season, three have won previously at Nashville Superspeedway in either the NASCAR Xfinity Series or the NASCAR Camping World Truck Series – Kevin Harvick (2006, 2010 NXS), Austin Dillon (2011 NCWTS) and Brad Keselowski (2008, 2010 NXS).</p><p> </p><p><u>Playoff Outlook: Drivers Without Wins</u></p><table width="100%"> <tbody> <tr> <td width="7%"><p><strong>Rank</strong></p></td> <td width="19%"><p><strong>Driver</strong></p></td> <td width="13%"><p><strong>Points</strong></p></td> <td width="13%"><p><strong>Race Wins</strong></p></td> <td width="13%"><p><strong>Stage Wins</strong></p></td> <td width="13%"><p><strong>Playoff Pts</strong></p></td> <td width="19%"><p><strong>Pts From Cutoff</strong></p></td> </tr> <tr> <td width="7%"><p>13</p></td> <td width="19%"><p>Ryan Blaney</p></td> <td width="13%"><p>511</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>4</p></td> <td width="13%"><p>4</p></td> <td width="19%"><p>95</p></td> </tr> <tr> <td width="7%"><p>14</p></td> <td width="19%"><p>Martin Truex Jr.</p></td> <td width="13%"><p>481</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>3</p></td> <td width="13%"><p>3</p></td> <td width="19%"><p>65</p></td> </tr> <tr> <td width="7%"><p>15</p></td> <td width="19%"><p>Christopher Bell</p></td> <td width="13%"><p>444</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>28</p></td> </tr> <tr> <td width="7%"><p>16</p></td> <td width="19%"><p>Aric Almirola</p></td> <td width="13%"><p>423</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>7</p></td> </tr> <tr> <td width="7%"><p>17</p></td> <td width="19%"><p>Kevin Harvick</p></td> <td width="13%"><p>416</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-7</p></td> </tr> <tr> <td width="7%"><p>18</p></td> <td width="19%"><p>Tyler Reddick</p></td> <td width="13%"><p>381</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>2</p></td> <td width="13%"><p>2</p></td> <td width="19%"><p>-42</p></td> </tr> <tr> <td width="7%"><p>19</p></td> <td width="19%"><p>Austin Dillon</p></td> <td width="13%"><p>376</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-47</p></td> </tr> <tr> <td width="7%"><p>20</p></td> <td width="19%"><p>Erik Jones</p></td> <td width="13%"><p>368</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-55</p></td> </tr> <tr> <td width="7%"><p>21</p></td> <td width="19%"><p>Michael McDowell</p></td> <td width="13%"><p>330</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-93</p></td> </tr> <tr> <td width="7%"><p>22</p></td> <td width="19%"><p>Chris Buescher</p></td> <td width="13%"><p>318</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-105</p></td> </tr> <tr> <td width="7%"><p>23</p></td> <td width="19%"><p>Justin Haley</p></td> <td width="13%"><p>310</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-113</p></td> </tr> <tr> <td width="7%"><p>24</p></td> <td width="19%"><p>Ricky Stenhouse Jr.</p></td> <td width="13%"><p>288</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-135</p></td> </tr> <tr> <td width="7%"><p>25</p></td> <td width="19%"><p>Bubba Wallace</p></td> <td width="13%"><p>284</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>1</p></td> <td width="13%"><p>1</p></td> <td width="19%"><p>-139</p></td> </tr> <tr> <td width="7%"><p>26</p></td> <td width="19%"><p>Ty Dillon</p></td> <td width="13%"><p>270</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-153</p></td> </tr> <tr> <td width="7%"><p>27</p></td> <td width="19%"><p>Cole Custer</p></td> <td width="13%"><p>262</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-161</p></td> </tr> <tr> <td width="7%"><p>28</p></td> <td width="19%"><p>Harrison Burton #</p></td> <td width="13%"><p>241</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-182</p></td> </tr> <tr> <td width="7%"><p>29</p></td> <td width="19%"><p>Todd Gilliland #</p></td> <td width="13%"><p>239</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="19%"><p>-184</p></td> </tr> <tr> <td width="7%"><p>30</p></td> <td width="19%"><p>Brad Keselowski</p></td> <td width="13%"><p>227</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>0</p></td> <td width="13%"><p>-10</p></td> <td width="19%"><p>-196</p></td> </tr> </tbody> </table><p><strong> </strong></p><p><strong> </strong></p><p><strong>Next Gen is giving the fans what they want – great competition</strong></p><p>Action-packed racing has been the norm this season thanks to the introduction of the Next Gen car in the NASCAR Cup Series and with 16 races in the books, the stats keep adding up.</p><p> </p><p>A total of 12 different race winners through the first 16 races of the 2022 season ties the 2000 and 2012 seasons for second-most winners through 16 races in the Modern Era (1972-2022); behind the 2003 season with 13 winners.</p><p> </p><p>A total of 10 different pole winners through the first 16 races of the 2022 season are the most since 2014 (11 poles winners)<em>.</em></p><p> </p><p>Of the 12 different race winners this season, four are first-time Cup Series winners: Team Penske’s Austin Cindric (Daytona 500), Stewart-Haas Racing’s Chase Briscoe (Phoenix) and Trackhouse Racing’s Ross Chastain (COTA) and Daniel Suárez (Sonoma). The NASCAR Cup Series record for the most first-time winners in a single season in the Modern Era (1972-2022) is five first-time winners, and it has occurred three times – 2001, 2002 and 2011.</p><p> </p><p>The average Margin of Victory of the first 16 races of the 2022 NASCAR Cup Series season is 0.710-second; the second closest average Margin of Victory through the first 16 races of a season since advent of electronic scoring in 1993; the closest is 2014 with 0.691-second. The first 16 races of the 2022 season have produced a Cup Series record of 12 races concluding with a Margin of Victory of less than a second.</p><p> </p><p>A total of 35 different drivers have led laps in the NASCAR Cup Series through the first 16 races of the season with an average of 10.31 leaders per race; up from last season’s 8.90 (+15.3%). The most average leaders per race since 2014 (11.50). </p><p> </p><p>The average number of lead changes through the first 16 races of the 2022 NASCAR Cup Series season is 21.0; up from last season’s 17.9 (+17.4%) - the most average lead changes per race since 2014 (25.4).  </p><p> </p><p>The 2022 NASCAR Cup Series season has also produced 786 green flag passes for the lead; the series-most through the first 16 races of a season since the Loop Data statistic was initially tabulated in 2007 (<em>the last 16 seasons</em>). The 2022 NASCAR Cup Series season is averaging 49.1 green flag passes for the lead per race – up <u>+35.3%</u> from the 16-year average of 31.8 per race.</p><p> </p><p>A total of seven tracks have set records in green flag passes for the lead this season; including Circuit of The Americas (30 GFPL), Atlanta Motor Speedway (141 GFPL), Las Vegas Motor Speedway (57 GFPL), Bristol Motor Speedway Dirt (20 GFPL) Darlington Raceway (28 GFPL), Kansas Speedway (41 GFPL) and Charlotte Motor Speedway (64 GFPL). Previous best GFPL totals were  - COTA (14 in 2021), Atlanta (44 in 2015), Las Vegas (56 in 2021), Bristol Dirt (8 in 2021), Darlington (tied previous record in 2008), Kansas (tied previous record of 41 in 2019) and Charlotte (48 in 2012 Playoff race).</p><p> </p><p>Plus, the 2022 NASCAR Cup Series season has produced 55,452 total green flag passes throughout the field; the seventh-most through the first 16 races of a season since the Loop Data statistic was initially tabulated in 2007 (<em>the last 16 seasons</em>). The 2022 NASCAR Cup Series season is averaging 3,466 total green flag passes per race – up <u>+2.53%</u> from the 16-year average of 3,378 per race.</p><p> </p><p>Three tracks this season have set track records in total green flag passes - Atlanta (6,439), Richmond (3,072) and Bristol Dirt (2,703).</p><p> </p><p><strong><u>NASCAR Cup Series, Etc. </u></strong></p><p><strong><em>Stage stats from the 2022 season –</em></strong> Following the 16th race of the 2022 NASCAR Cup Series season, all but one fulltime series driver has scored stage points this season – Corey LaJoie is the only driver without a single stage point.</p><p> </p><p>Hendrick Motorsport’s driver Chase Elliott has scored the most stage points with 136 of his total 536 points this season coming from stage points (25.3%).</p><p> </p><p>Team Penske’s Ryan Blaney has won the most stages this season through 16 races with four stage wins.  </p><p> </p><p><strong><u>NASCAR Xfinity Series</u></strong></p><p> </p><p><strong>One more off week: Nashville Superspeedway up next </strong></p><p>The NASCAR Xfinity Series has yet another off week before coming back to the track for the Tennessee Lottery 250 at Nashville Superspeedway on June 25 at 3:30 p.m. ET on USA Network, MRN and SiriusXM NASCAR radio.</p><p> </p><p>There are seven drivers who can breathe easy for next weekend’s Nashville race as they’ve already clinched their spot in this season’s Playoffs – Ty Gibbs, Noah Gragson, AJ Allmendinger, Justin Allgaier, Josh Berry, Brandon Jones and Austin Hill – leaving just five spots up for grabs.</p><p> </p><p>Currently in the eighth position is JR Motorsports’ Sam Mayer with a 137-point cushion ahead of the Playoff cutoff. Although he has yet to post a win this season, don’t be surprised if he joins JRM teammates Gragson, Allgaier and Berry on this season’s winners list as he has posted seven top fives and eight top 10s thus far.</p><p> </p><p>Sliding into the ninth-place position is Daniel Hemric with 389 points, one top five and six top 10s. Twenty three points behind Hemric sits Landon Cassill, who is having a career-year, with three top fives and seven top 10s.</p><p> </p><p>Rounding out the last two slots in the current Playoff outlook are Stewart-Haas Racing’s Riley Herbst (77-point cushion ahead of the cutline) and RSS Racing’s Ryan Sieg (58-points above the cutline).</p><p> </p><p>Herbst had rough finishes in the last two Xfinity Series races but was previously riding a streak of six consecutive top-10 finishes, so he still has plenty of time to get back on track. His best finish this season thus far was a third place at Darlington Raceway. Considering that Darlington Raceway and Nashville Superspeedway are almost identical in length, perhaps he’ll finally make his way to Victory Lane and clinch his spot in the Playoffs.</p><p> </p><p>On the cusp of the postseason cutline is Anthony Alfredo in 13th, the first spot outside the Playoffs, but he’s 58 points behind Ryan Sieg in 12th. Alfredo scored his first career pole in Portland and is hoping to run well when he makes his series track debut at Nashville. Alfredo is chasing Sieg in the points, and Sieg made his series track debut at Nashville last season posting a 16th-place finish.  </p><p> </p><p><strong>Xfinity Series regulars keep up the momentum  </strong></p><p>While most Xfinity Series drivers are enjoying their well-deserved break in the season, Josh Berry and Brandon Jones spent the weekend perfecting their skills and adding wins to their resumes.</p><p> </p><p>Berry, who drives the No.8 JR Motorsports Chevrolet, found his way to Victory Lane in the inaugural Jack Ingram Memorial 111 Late Model race at Hickory Motor Speedway on Saturday, June 11.</p><p> </p><p>With the win, Berry can say that he has victories at every active crown jewel at Hickory, including the Fall Brawl and the Bobby Isaac Memorial.</p><p> </p><p>While Berry was cruising into Victory Lane at Hickory Motor Speedway, Jones was doing the same at Iowa Speedway for the Calypso Lemonade 150 in the ARCA Menards Series.</p><p> </p><p>Jones is two-for-two in ARCA Menards races this season, having also won last month’s Charlotte race. In total, he has posted seven ARCA Menards Series wins since 2014 and plans to take home more trophies as he’s set to make three more starts in the No.81 Joe Gibbs Racing Toyota at Pocono Raceway on July 22, Watkins Glen on August 19 and Bristol Motor Speedway on September 15.</p><p> </p><p>Both drivers have already snagged Xfinity Series wins this season (Berry – Dover and Charlotte &amp; Jones – Martinsville) and they each have had one stint at the Nashville track, both finishing in the top 10.</p><p> </p><p><strong><u>NASCAR Xfinity Series, Etc.</u></strong></p><p><strong><em>Sammy Smith set to start eight races in the Xfinity Series –</em></strong> Sammy Smith, the reigning ARCA Menards Series East champion with Joe Gibbs Racing has now been called up to pilot the No. 18 JGR Toyota in select races in the NASCAR Xfinity Series. </p><p> </p><p>His Xfinity Series career debut will be at Road America on Saturday, July 2. He will also be behind the wheel for the races at Pocono Raceway, Michigan International Speedway, Watkins Glen International, Kansas Speedway, Bristol Motor Speedway, Martinsville Speedway and Phoenix Raceway.</p><p> </p><p>The 18-year-old driver will be the seventh to pilot the No.18 this season after Trevor Bayne, Ryan Truex, Drew Dollar, John Hunter Nemechek, Bubba Wallace and Connor Mosack.</p><p> </p><p><strong><em>One Xfinity driver entered in Knoxville this weekend –</em></strong> Brett Moffitt, driver of the No. 02 Our Motorsports Chevrolet in the NASCAR Xfinity Series, will be starting in his first NASCAR Camping World Truck Series race of the season for AM Racing in the No. 22 Chevrolet.</p><p> </p><p>This will be the 2018 NASCAR Camping World Truck Series champion Moffitt’s 91st start in the series. In addition to his series title, he has posted 12 wins, 39 top fives and 53 top 10s.</p><p> </p><p>This season in the Xfinity Series, he’s started in all 14 races posting three top 10s.</p><p> </p><p><strong><em>Hendrick Motorsports to join in on Xfinity Series fun –</em></strong> Hendrick Motorsports will be bringing back the No. 17 for three NASCAR Xfinity Series road courses this season with Kyle Larson, Alex Bowman and William Byron each taking their turn behind the wheel.</p><p> </p><p>Hendrick Motorsports has deep ties to the No. 17, fielding it for Darrell Waltrip from 1987-90 and claiming a Daytona 500 victory before running the same number in the Camping World Truck Series for Ricky Hendrick, the late son of team owner Rick Hendrick.</p><p> </p><p>The car will run at Road America on July 2, Indianapolis Motor Speedway Road Course on July 30 and Watkins Glen International on Aug. 20.</p><p> </p><p><strong><u>NASCAR Camping World Truck Series</u></strong></p><p> </p><p><strong>Digging Up The Dirt: Camping World Truck Series heads to Knoxville Raceway</strong></p><p>For the second time in NASCAR Camping World Truck Series history, the series will venture to Knoxville Raceway for this weekend’s Clean Harbors 150 on Saturday, June 18 at 9 p.m. ET on FS1, MRN and SiriusXM NASCAR Radio.</p><p> </p><p>This weekend’s event is guaranteed to have a new winner as last year’s victor, Austin Hill, is not entered to defend his win. Last season’s race was a wild one, producing 20 lead changes among seven different drivers. Kyle Busch Motorsport’s driver Chandler Smith led the most laps (71) and McAnally Hilgemann Racing’s Derek Kraus won the first two stages but it was Hattori Racing Enterprises’ Austin Hill who took the checkered flag in the inaugural event on the famous dirt track.</p><p> </p><p>In total, the NASCAR Camping World Truck Series has run 10 races on dirt at three different tracks – Eldora Speedway (2013-2019, seven races), Bristol Motor Speedway Dirt (2021-2022, two races) and Knoxville Raceway (2021, one race) producing 10 different winners – at Eldora: Austin Dillon (2013), Bubba Wallace (2014), Christopher Bell (2015), Kyle Larson (2016), Matt Crafton (2017), Chase Briscoe (2018) and Stewart Friesen (2019); at Bristol Dirt: Martin Truex Jr. (2021) and Ben Rhodes (2022); and at Knoxville Raceway Austin Hill (2021).</p><p> </p><p>This season, the series returns to the half-mile dirt track, Knoxville Raceway, looking for more great racing action. The Clean Harbors 150 will be 75 miles in length (150 laps) and will be broken up into three stages. The first stage will end on lap 40, the second stage will end on lap 90 and the final stage is scheduled to conclude on lap 150.</p><p> </p><p>Three former winners on dirt in the NASCAR Camping World Truck Series are entered this weekend at Knoxville Raceway - Matt Crafton (Eldora 2017), Stewart Friesen (Eldora 2019) and Ben Rhodes (Bristol Dirt 2022).</p><p> </p><p><strong>Standings leader Ben Rhodes is looking to sweep some dirt this season</strong></p><p>For just the second time in NASCAR Camping World Truck Series history, the season schedule offers two races on dirt (Bristol Motor Speedway Dirt and Knoxville Raceway) and this weekend ThorSport Racing’s Ben Rhodes, the winner of the Bristol Dirt race earlier this season, is looking to sweep this year’s dirt events by taking the win this weekend in the Clean Harbors 150 at Knoxville Raceway on Saturday, June 18 at 9 p.m. ET on FS1, MRN and SiriusXM NASCAR Radio.</p><p> </p><p>Last season in the NASCAR Camping World Truck Series, Martin Truex Jr. won the Bristol Dirt race for Kyle Busch Motorsports and Hattori Racing Enterprises’ Austin Hill grabbed the win at Knoxville.</p><p> </p><p>This season, Rhodes dominated the Truck Series race at Bristol Motor Speedway Dirt, leading 95 of the scheduled 150 laps (63.3%) and taking the win. Now the 25-year-old has the opportunity to become the first in series history to pull the ‘dirt sweep’ if he wins this weekend at Knoxville.</p><p> </p><p>Last season at Knoxville, Rhodes started 18th and raced his way up to a seventh-place finish.</p><p> </p><p><strong>Knoxville Raceway: Dirt - Qualifying &amp; Race Formats</strong></p><p>This weekend’s racing will have special formats for the NASCAR Camping World Truck Series race. Below are details on the 2022 Knoxville Dirt qualifying and race formats:</p><p> </p><ul> <li><strong>Qualifying Race Starting Lineup</strong> – Random draw determines qualifying race designation and starting position for the qualifying race.</li> </ul><p> </p><ul> <li><strong>Qualifying Races</strong> – Four qualifying races held at <strong><em>15 laps each</em></strong> with only green flag laps counted – no overtime rule. Free pass and wave around procedures will be in effect.</li> </ul><p> </p><ul> <li><strong>Points Earned During Qualifying Races </strong>– Drivers will accumulate points in the qualifying races based on finishing position and passing points. The points total of a driver’s passing points and race finishing position points determines the starting position for the feature event.</li> </ul><p> </p><ul> <li><strong>Passing Points = </strong>The difference between assigned starting position and finishing position</li> </ul><p> </p><ul> <li><strong>Go forward – </strong>accumulate passing points</li> </ul><p> </p><ul> <li><strong>Go backward or finish where you started</strong> – zero passing points</li> </ul><p> </p><ul> <li><strong>Race Finishing Position Points </strong>= Points received for the driver’s finishing position</li> </ul><p> </p><table> <tbody> <tr> <td><p><strong>Finish</strong></p></td> <td> </td> <td><p><strong>Points</strong></p></td> <td> </td> </tr> <tr> <td><p><strong>1</strong></p></td> <td> </td> <td><p><strong>10</strong></p></td> <td> </td> </tr> <tr> <td><p><strong>2</strong></p></td> <td> </td> <td><p><strong>9</strong></p></td> <td> </td> </tr> <tr> <td><p><strong>3</strong></p></td> <td> </td> <td><p><strong>8</strong></p></td> <td> </td> </tr> <tr> <td><p><strong>4</strong></p></td> <td> </td> <td><p><strong>7</strong></p></td> <td> </td> </tr> <tr> <td><p><strong>5</strong></p></td> <td> </td> <td><p><strong>6</strong></p></td> <td> </td> </tr> <tr> <td><p><strong>6</strong></p></td> <td> </td> <td><p><strong>5</strong></p></td> <td> </td> </tr> <tr> <td><p><strong>7</strong></p></td> <td> </td> <td><p><strong>4</strong></p></td> <td> </td> </tr> <tr> <td><p><strong>8</strong></p></td> <td> </td> <td><p><strong>3</strong></p></td> <td> </td> </tr> <tr> <td><p><strong>9</strong></p></td> <td> </td> <td><p><strong>2</strong></p></td> <td> </td> </tr> </tbody> </table><ul> <li><strong>Tiebreaker -</strong> Owner Points   </li> </ul><p>                             </p><ul> <li><strong>Feature Main – </strong>Lineup based on combined points of Qualifying Race finishing position and passing points. Feature race will be <strong>150 laps</strong> divided into three stages 40/90/150. Running order will be frozen at the conclusion of each stage. During the stage breaks, teams can change tires, add fuel, and make adjustments to their trucks. These non-competitive pit stops must be completed in a time designated by NASCAR. <strong>No fuel or tires except at stage breaks.</strong> <strong> Flat or damaged tires may be changed with approval by NASCAR.</strong> <em>(Note: Teams will not be required to pit during the stage breaks. Teams that elect not to pit will re-start ahead of teams that pitted. Re-start order determined by the freeze at the conclusion of the preceding stage)</em></li> </ul><p> </p><ul> <li><strong>Additional Event Highlights – </strong>Choose rule will not be in effect for the Knoxville race. The overtime rules, free pass and wave around procedures will be in effect. </li> </ul><p> </p><p><strong>Dirt Ringers: The specialists on dirt brought in for Knoxville </strong></p><p>As the NASCAR Camping World Truck Series heads to its second dirt track on the schedule, a handful of ‘dirt ringers’ will be making their way to Knoxville Raceway this weekend. Within this group will be up and comer Buddy Kofoid, Toyota Racing Development driver who will be making his second start of the season in the Kyle Busch Motorsports No. 51 Toyota Tundra. Kofoid’s 2022 season has involved racing for a second consecutive USAC National Midget Series championship along with fielding starts in Dirt Sprint Cars and Champ Cars. Coming fresh off a USAC Indiana Midget Week Title for Keith Kuntz Racing, the 20-year-old will look to carry this momentum into a truck and improve on a 27th-place outing in the Bristol Dirt Race earlier this year.</p><p> </p><p>Another dirt specialist looking to grab the attention of his competition is Brayton Laster. The Greenwood, Indiana native will be making his NASCAR Camping World Truck Series debut in the Reaume Brothers Racing No. 33 Toyota Tundra. Laster, 19, has been touring the Midwest running Dirt Super Late Models for the last four years, earning the title of Brownstown Speedway Rookie of the Year in 2018, as well as finishing third in the Ultimate Heart of America Super Late Model Series standings in 2021. Having recently made starts at Daytona and Talladega in the ARCA Menard’s Series this year, Laster hopes to continue making headway in NASCAR at Knoxville.</p><p> </p><p>Jessica Friesen, wife of NASCAR Camping World Truck Series regular Stewart Friesen, will also be preparing to race this weekend. The former Dirt Sprint Car racer will be piloting the Halmar Friesen Racing No. 62 Toyota Tundra. Last year’s Knoxville Clean Harbor 150 acted as Friesen’s debut in the Truck Series. Having finished 26th in the event, she will look to exceed her previous result and showcase her prowess on dirt against her spouse and the rest of the field.</p><p> </p><p>In addition, siblings Bryson and Braden Mitchell will look to outdo each other and the competition as both are poised to make starts at Knoxville this weekend. Bryson will be driving for G2G Racing in the No. 46 Toyota Tundra while Braden will be wheeling the No. 53 Sparks Motorsports Chevy Silverado. Bryson has recently made a select number of starts in the Durrence Layne Chevrolet Dirt Late Model Series and is primed to utilize his dirt skillset to perform this weekend. On the other hand, Braden looks to overshadow his last time in a truck at Eldora Speedway in 2018, where he failed to qualify for the event.</p><p> </p><p><strong><u>NASCAR Camping World Truck Series, Etc.</u></strong></p><p> </p><p><strong><em>The Friesens take on Knoxville in the Camping World Truck Series – </em></strong>For the second year-in-a-row, the Friesens – Stewart and Jessica - a married couple, will attempt to compete against each other in the NASCAR Camping World Truck Series race at Knoxville Raceway. Jessica Friesen, a well-known sprint car and modifieds dirt racer, will attempt to make her 2022 season debut in the Camping World Truck Series driving the No. 62 Halmar Friesen Racing Toyota alongside the familiar No. 52 of husband Stewart Friesen.</p><p> </p><p>The Friesens have competed against each other before, finishing first and second in a race at Utica-Rome Speedway two days after their wedding in 2014. Then last season, Jessica and Stewart competed in the same NASCAR Camping World Truck Series race at Knoxville Raceway. Jessica ultimately finished one spot better than her husband Stewart in the event taking home 26th and 27th-place finishes, respectively.</p><p> </p><p>It was the first time a husband-wife duo competed in the same NASCAR national series race since Elton Sawyer and Patty Moise last did it at Atlanta Motor Speedway in the NASCAR Xfinity Series in 1998.</p><p> </p><p>This weekend, the Friesens will look to add another race to the list they have both competed in when they attempt to compete in this Saturday’s Clean Harbors 150 at Knoxville Raceway. Earlier this season, Jessica attempted to qualify for the Bristol Dirt event but did not make the race.</p><p>NASCAR PR</p></div><div class="clr"></div><div class="itemToolbarContent"><div class="itemRatingBlock"> <span>Rate this item</span> <div class="itemRatingForm"><ul class="itemRatingList"> <li class="itemCurrentRating" id="itemCurrentRating70486" style="width:0%;"></li> <li><a ondragstart="return false;" href="#" data-id="70486" title="1 star out of 5" class="one-star">1</a></li> <li><a ondragstart="return false;" href="#" data-id="70486" title="2 stars out of 5" class="two-stars">2</a></li> <li><a ondragstart="return false;" href="#" data-id="70486" title="3 stars out of 5" class="three-stars">3</a></li> <li><a ondragstart="return false;" href="#" data-id="70486" title="4 stars out of 5" class="four-stars">4</a></li> <li><a ondragstart="return false;" href="#" data-id="70486" title="5 stars out of 5" class="five-stars">5</a></li> </ul><div id="itemRatingLog70486" class="itemRatingLog">(0 votes)</div><div class="clr"></div></div><div class="clr"></div></div><div class="itemToolbar float-right"><ul> <li> <span class="itemTextResizerTitle">font size</span> <a ondragstart="return false;" href="#" id="fontDecrease"> <span>decrease font size</span> </a> <a ondragstart="return false;" href="#" id="fontIncrease"> <span>increase font size</span> </a> </li> <li> <a ondragstart="return false;" class="itemPrintLink" rel="nofollow" href="/index.php/news/nascar-truck-series-news/70486-nascar-national-series-news-notes-knoxville-raceway?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;"> <span>Print</span> </a> </li> <li> <a ondragstart="return false;" class="itemEmailLink" rel="nofollow" href="/index.php/component/mailto/?tmpl=component&amp;template=ts_newslinen&amp;link=2535b09a933284ddb5c978c7acb0de216cc6f841" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;"> <span>Email</span> </a> </li> </ul><div class="clr"></div></div></div><div class="itemContentFooter"><div class="clr"></div></div><div class="clr"></div></div><div class="itemSocialSharing"><div class="itemTwitterButton"> <a ondragstart="return false;" href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="">Tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','twitter-wjs');</script> </div><div class="itemFacebookButton"><div id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script><div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div></div><div class="clr"></div></div><div class="itemLinks"><div class="clr"></div></div><div class="itemNavigation"> <a ondragstart="return false;" class="itemPrevious" href="/index.php/news/nascar-truck-series-news/70483-toyota-racing-weekly-preview-06-15-22">&laquo; Toyota Racing - Weekly Preview - 06.15.22</a> <a ondragstart="return false;" class="itemNext" href="/index.php/news/nascar-truck-series-news/70491-gms-racing-ncwts-race-preview-knoxville">GMS Racing NCWTS Race Preview: Knoxville &raquo;</a> </div><div class="itemAuthorBlock"> <img ondragstart="return false;" class="itemAuthorAvatar jch-lazyload" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/users/13.png" alt="Speedway Digest Staff" /><noscript><img ondragstart="return false;" class="itemAuthorAvatar" src="/media/k2/users/13.png" alt="Speedway Digest Staff" /></noscript><div class="itemAuthorDetails"><h3 class="itemAuthorName"> <a ondragstart="return false;" rel="author" href="/index.php/news/nascar-truck-series-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </h3><p><p>Follow us on Twitter <a ondragstart="return false;" href="https://www.twitter.com/speedwaydigest">@SpeedwayDigest</a></p></p><div class="clr"></div><div class="clr"></div></div><div class="clr"></div></div><div class="itemAuthorLatest"><h3>Latest from Speedway Digest Staff</h3><ul> <li class="even"> <a ondragstart="return false;" href="/index.php/news/speedway-news/70552-rich-hammann-leads-stafford-limited-late-models-into-extra-distance-race">Rich Hammann Leads Stafford Limited Late Models Into Extra Distance Race</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/speedway-news/70551-michael-waltrip-says-srx-event-at-south-boston-speedway-will-be-a-fun-night">Michael Waltrip Says SRX Event at South Boston Speedway Will Be a Fun Night</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news/70550-canadian-sprint-car-driver-dylan-westbrook-to-join-jordan-anderson-racing-bommarito-autosport-at-knoxville-raceway">Canadian Sprint Car Driver Dylan Westbrook to Join Jordan Anderson Racing Bommarito Autosport at Knoxville Raceway</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news/70549-nbc-sports-nascar-commentary-team-ready-for-2022-season">NBC Sports’ NASCAR Commentary Team Ready for 2022 Season</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/speedway-news/70545-milwaukee-mile-racing-ready-father-s-day-sunday-june-19th">Milwaukee Mile Racing Ready Father's Day Sunday, June 19th</a> </li> </ul><div class="clr"></div></div><div class="clr"></div><div class="itemBackToTop"> <a ondragstart="return false;" class="k2Anchor" href="/index.php/news/nascar-truck-series-news/70486-nascar-national-series-news-notes-knoxville-raceway#startOfPageId70486"> back to top </a> </div><div class="clr"></div></div></div></main><aside id="sp-right" class="col-lg-4 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div></div></aside></div></div></div></section><footer id="sp-footer" class="ts-footer"><div class="row"><div id="sp-footer1" class="col-lg-6 "><div class="sp-column text-center"><span class="sp-copyright">Copyright © 2010 - 2022 STS Motorsports Inc. All Rights Reserved.</span></div></div><div id="sp-footer2" class="col-lg-6 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><ul class="menu nav-pills"> <li class="item-1557"><a ondragstart="return false;" href="/index.php/advertise">Advertise</a></li><li class="item-1559"><a ondragstart="return false;" href="/index.php/privacy-policy">Privacy Policy</a></li><li class="item-1621"><a ondragstart="return false;" href="/index.php/sitemap">Sitemap</a></li><li class="item-1558"><a ondragstart="return false;" href="/index.php/sd-staff">SD Staff</a></li><li class="item-1576"><a ondragstart="return false;" href="/index.php/writer-login">Writer Login</a></li></ul></div></div></div></div></div></footer></div></div><div class="offcanvas-overlay"></div><div class="offcanvas-menu"> <a ondragstart="return false;" href="#" class="close-offcanvas"><span class="fa fa-remove"></span></a> <div class="offcanvas-inner"><div class="sp-module "><div class="sp-module-content"><ul class="menu"> <li class="item-241 default"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="item-186 active menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/news">News<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-205"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="item-188"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="item-1922 current active"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="item-190"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="item-207"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="item-2153"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="item-1876"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></li><li class="item-197 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-198"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="item-199"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="item-200"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="item-202"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></li><li class="item-208 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-209"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="item-210"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="item-211"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></li><li class="item-204 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-235"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="item-236"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="item-237"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="item-1596"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></li><li class="item-606"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></div></div></div></div> <a ondragstart="return false;" href="#" class="sp-scroll-up" aria-label="Scroll Up"><span class="fa fa-chevron-up" aria-hidden="true"></span></a> <amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-auto-format="rspv" data-full-width=""><div overflow=""></div></amp-ad><div id="openModal" class="modalDialog"><div> <a ondragstart="return false;" href="#close" title="Close" id="close" class="close">X</a> <h2>No right click</h2><p>Please link the article. </p></div></div> <script type="text/javascript">disableSelection(document.body)</script> </body> </html>