<!doctype html><html prefix="og: http://ogp.me/ns#" lang="en-gb" dir="ltr"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="canonical" href="https://www.speedwaydigest.com/index.php/news/nascar-cup-series-news/65513-weekend-preview-charlotte-motor-speedway-road-course"><base href="https://www.speedwaydigest.com/index.php/news/nascar-cup-series-news/65513-weekend-preview-charlotte-motor-speedway-road-course" /><meta http-equiv="content-type" content="text/html; charset=utf-8" /><meta name="keywords" content="NASCAR, NASCAR News, NASCAR Drivers, NASCAR Frequencies, NASCAR Cup Series, Monster Cup, XFINITY, Xfinity Series, Camping World, Camping World Truck Series, NASCAR Points, Speedway Digest, Speedway Digest NASCAR News, Daytona, Richmond, Martinsville, Dover, Charlotte, Darlington, North Wilkesboro, Texas Motor Speedway, Pocono Speedway, Watkins Glen, Auto Club Speedway, Bristol Motor Speedway, Kansas Speedway, Talladega Superspeedway, Atlanta Motor Speedway, News, Jimmie Johnson, Roush Racing, Hendricks Motorsports, BK Racing, Wood Brothers Racing, Richard Petty Motorsports, Yates Racing, Robert Yates Racing, Michael Waltrip Racing, Carl Edwards, Trevor Bayne, Save The Speedway, North Wilkesboro Speedway, Dale Earnhardt, Dale Earnhardt Jr., NASCAR Frequencies, Monster Energy NASCAR Cup Series, Monster Energy Series, XFINITY Series, Camping World Truck Series, Las Vegas Motor Speedway, Phoenix International Raceway, Charlotte Motor Speedway, New Hampshire Motor Speedway, Gateway Motorsports Park, Darlington Raceway, Ryan Blaney, Chase Elliott, Ford Performance, Team Chevy, Toyota Racing, Kyle Busch, Kurt Busch, Denny Hamlin, NASCAR schedule, nascar race today, nascar race schedule, nascar race results, nascar race this weekend, nascar race results today, nascar truck race, nascar trucks, where is the nascar race today, nascar xfinity race, nascar schedule, nascar news, daytona 500, nascar race today, nascar today, nascar race, nascar results, nascar race schedule, nascar live, race scanner, racing scanner, race scanners" /><meta name="rights" content="Copyright - Steven B. Wilson - STS Motorsports Inc. 2005 - 2021" /><meta name="author" content="Speedway Digest Staff" /><meta property="og:url" content="https://www.speedwaydigest.com/index.php/news/nascar-cup-series-news/65513-weekend-preview-charlotte-motor-speedway-road-course" /><meta property="og:type" content="article" /><meta property="og:title" content="Weekend Preview: Charlotte Motor Speedway Road Course" /><meta property="og:description" content="Eliminations loom for Cup Playoff drivers at Charlotte Motor Speedway Road Course The Charlotte Motor Speedway Road Course (ROVAL) is set to punctuate what has been a thrilling and unpredictable second round of the 2021 NASCAR Cup Series Playoffs with Sunday’s Bank of America ROVAL 400 (2 p.m. ET on..." /><meta property="og:image" content="https://www.speedwaydigest.com/media/k2/items/cache/a3fd7daacdc1eb9960009dfac9b08b5a_M.jpg" /><meta name="image" content="https://www.speedwaydigest.com/media/k2/items/cache/a3fd7daacdc1eb9960009dfac9b08b5a_M.jpg" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Weekend Preview: Charlotte Motor Speedway Road Course" /><meta name="twitter:description" content="Eliminations loom for Cup Playoff drivers at Charlotte Motor Speedway Road Course The Charlotte Motor Speedway Road Course (ROVAL) is set to punctuate what has been a thrilling and unpredictable secon..." /><meta name="twitter:image" content="https://www.speedwaydigest.com/media/k2/items/cache/a3fd7daacdc1eb9960009dfac9b08b5a_M.jpg" /><meta name="twitter:image:alt" content="Weekend Preview: Charlotte Motor Speedway Road Course" /><meta name="description" content="Eliminations loom for Cup Playoff drivers at Charlotte Motor Speedway Road Course The Charlotte Motor Speedway Road Course (ROVAL) is set to punctuate..." /><meta name="generator" content="Helix Ultimate - The Most Popular Joomla! Template Framework." /><title>Weekend Preview: Charlotte Motor Speedway Road Course</title><link href="/index.php/news/nascar-cup-series-news/65513-weekend-preview-charlotte-motor-speedway-road-course" rel="canonical" /><link href="https://www.speedwaydigest.com/index.php/news/nascar-cup-series-news/65513-weekend-preview-charlotte-motor-speedway-road-course/amp" rel="amphtml" /><link href="/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /><link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /> <script type="application/json" class="joomla-script-options new">{"data":{"breakpoints":{"tablet":991,"mobile":480},"header":{"stickyOffset":"100"}},"csrf.token":"ec760e31f2048caabb217176ceac1279","system.paths":{"root":"","base":""}}</script> <script type="application/ld+json">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</script><meta http-equiv="imagetoolbar" content="no"><link rel="preload" as="style" href="/media/com_jchoptimize/cache/css/494cfb6af0cbbb59be3b19f085aa6f7c.css" onload="this.rel='stylesheet'" /><style id="jch-optimize-critical-css">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</style> <script src="/media/com_jchoptimize/cache/js/bb8a6e95a5d0ec839effc8210b6de2ae.js"></script> <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <script src="/media/com_jchoptimize/cache/js/e2d7ba6051334931ede4752c517f1968.js"></script><noscript><style type="text/css">img.jch-lazyload,iframe.jch-lazyload{display:none}</style> </noscript> </head><body class="site helix-ultimate hu com-k2 view-item layout-default task-none itemid-205 en-gb ltr sticky-header layout-boxed offcanvas-init offcanvs-position-right"><div class="body-wrapper"><div class="body-innerwrapper"><section id="sp-top-bar" class="ts-top-bar-classic d-none d-sm-none d-md-block"><div class="container"><div class="container-inner"><div class="row"><div id="sp-top1" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div id="ts_date155" class="ts_date_area "> <i class="fa fa-calendar-check-o"> </i> Friday, Oct 08</div></div></div></div></div><div id="sp-top-menu" class="col-lg-3  d-md-none d-lg-block"><div class="sp-column "></div></div><div id="sp-top3" class="col-lg-7 "><div class="sp-column ts-top-social text-right"><ul class="social-icons"><li class="social-icon-facebook"><a ondragstart="return false;" target="_blank" href="https://www.facebook.com/speedwaydigest" aria-label="facebook"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a ondragstart="return false;" target="_blank" href="https://www.twitter.com/speedwaydigest" aria-label="twitter"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-pinterest"><a ondragstart="return false;" target="_blank" href="https://www.pinterest.com/speedwaydigest/" aria-label="Pinterest"><span class="fa fa-pinterest" aria-hidden="true"></span></a></li><li><a ondragstart="return false;" target="_blank" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A" aria-label="Youtube"><span class="fa fa-youtube" aria-hidden="true"></span></a></li></ul></div></div></div></div></div></section><section id="sp-logo-area"><div class="container"><div class="container-inner"><div class="row"><div id="sp-logo" class="col-md-4 col-lg-3 "><div class="sp-column "><div class="logo"><a ondragstart="return false;" href="/"><img ondragstart="return false;" class="logo-image d-none d-lg-inline-block" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"><img ondragstart="return false;" class="logo-image-phone d-inline-block d-lg-none" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"></a></div></div></div><div id="sp-top-banner-2" class="col-md-8 col-lg-9 d-none d-sm-none d-md-block"><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="7293211960" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></div></div></div></div></div></div></section><section id="sp-menu" class="ts-nav-box"><div class="container"><div class="container-inner"><div class="row"><div id="sp-menu" class="col-8 col-md-11 col-lg-12 "><div class="sp-column ts-menu"><nav class="sp-megamenu-wrapper" role="navigation"><a ondragstart="return false;" id="offcanvas-toggler" aria-label="Navigation" class="offcanvas-toggler-right d-block d-lg-none" href="#"><i class="fa fa-bars" aria-hidden="true" title="Navigation"></i></a><ul class="sp-megamenu-parent menu-animation-fade-up d-none d-lg-block"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="sp-menu-item sp-has-child active"><a ondragstart="return false;" href="/index.php/news">News</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item current-item active"><a ondragstart="return false;" aria-current="page" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></div></div></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></nav></div></div></div></div></div></section><section id="sp-main-body"><div class="container"><div class="container-inner"><div class="row"> <main id="sp-component" class="col-lg-8 "><div class="sp-column "><div id="system-message-container"> </div> <span id="startOfPageId65513"></span> <div id="k2Container" class="blog-details-content ts-content-box itemView"><div class="itemHeader"><h2 class="itemTitle"> Weekend Preview: Charlotte Motor Speedway Road Course </h2></div><div class="ItemMetaInfo"> <span class="itemAuthor"> <a ondragstart="return false;" rel="author" href="/index.php/news/nascar-cup-series-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </span> <div class="itemCategory"> <a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a> </div> <span class="itemDateCreated"> <i class="fa fa-clock-o"></i> Thursday, Oct 07 </span> <span class="itemHits"> <i class="icon-fire" aria-hidden="true"></i> 61 </span> </div><div class="itemBody"><div class="itemImageBlock"> <span class="itemImage"> <a ondragstart="return false;" data-k2-modal="image" href="/media/k2/items/cache/a3fd7daacdc1eb9960009dfac9b08b5a_XL.jpg" title="Click to preview image"> <img class="jch-lazyload" ondragstart="return false;" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/items/cache/a3fd7daacdc1eb9960009dfac9b08b5a_L.jpg" alt="Weekend Preview: Charlotte Motor Speedway Road Course" style="width:400px; height:auto;" /><noscript><img ondragstart="return false;" src="/media/k2/items/cache/a3fd7daacdc1eb9960009dfac9b08b5a_L.jpg" alt="Weekend Preview: Charlotte Motor Speedway Road Course" style="width:400px; height:auto;" /></noscript></a> </span> <div class="clr"></div></div><div class="itemFullText"><p><strong>Eliminations loom for Cup Playoff drivers at Charlotte Motor Speedway Road Course</strong></p><p>The Charlotte Motor Speedway Road Course (ROVAL) is set to punctuate what has been a thrilling and unpredictable second round of the 2021 NASCAR Cup Series Playoffs with Sunday’s Bank of America ROVAL 400 (2 p.m. ET on NBC, PRN and SiriusXM NASCAR Radio).</p><p>This four-year-old race on the Charlotte Road Course, which incorporates portions of the track’s speedway high banks with a challenging infield layout, has produced big time action in settling who advances to the Playoffs' Round of 8.</p><p>And although Hendrick Motorsports driver Chase Elliott has won the last two races, the competition has always been intense and the outcome more dramatic than statistics could suggest.</p><p>Elliott took the win over Team Penske's Joey Logano by a healthy 3.895-seconds last year to earn his second win in three races at the Charlotte ROVAL.</p><p>The 2018 inaugural race winner, Ryan Blaney, is the only other current Playoff driver to finish among the top-five last October. He has two top-five and three top-10 finishes in three races and his 4.7 average finish at the ROVAL is second only to Elliott’s amazing 2.667 average finish.</p><p>Only three other Playoff drivers earned top-10 finishes last year – William Byron (sixth), Martin Truex Jr. (seventh) and Alex Bowman (eighth). Kevin Harvick was 11th and current championship leader Denny Hamlin, who has already advanced to the second round with a win at Las Vegas two weeks ago, was 15th in last year’s ROVAL race.</p><p>Even with a 22-point cushion on the cutoff line going into Sunday’s race, the Regular Season Champion Kyle Larson doesn’t necessarily feel fully secure in his standing.</p><p>He knows first-hand this race can produce drama. And that’s certainly been the vibe in the 2021 Playoffs with Bubba Wallace – a non-Playoff driver - earning his first series career victory last week in Talladega, Ala. and only five Playoff drivers ranking among the final top 10 in the rain-shortened race.</p><p>In 2018, Larson took a 20-point advantage into the ROVAL, won the first stage and led a race best 47 laps only to get caught up in a multi-car accident with six laps remaining. He trudged on to finish 25th, but the outcome put him in a three-way tie for the final two transfer positions. He ultimately moved on - only prevailing in a tiebreaker.</p><p>Larson’s current crew chief Cliff Daniels said he’s got the ROVAL notes from Elliott’s team and is hopeful that will help derail any ROVAL drama. Larson scored a dominating win at the Sonoma, Calif. road course this summer leading 57 of 92 laps and won at the Watkins Glen, N.Y. road course as well.</p><p>“We’ve run first and second a lot this year on road courses," Larson said of himself and Elliott. “That team and Chase set the bar. You pay attention to how he’s doing and where he’s running. It’s been fun to compete with him on the road courses and we both have a couple wins. Hopefully, we’re battling with all our teammates for stage wins and the victory this weekend."</p><p>Larson’s ROVAL luck is a precautionary tale that makes some drivers nervous but also energizes others.</p><p>Beyond Hamlin and Larson, Joey Logano is ranked third in the Playoff standings followed by his Team Penske teammate Brad Keselowski and Joe Gibbs Racing’s Martin Truex Jr. Team Penske driver Ryan Blaney, Hendrick’s Elliott and Joe Gibbs Racing driver Kyle Busch round out the top-eight going into the ROVAL race.</p><p>Stewart-Haas Racing’s Kevin Harvick, the 2014 Cup Series champion, is ranked ninth, however, only nine-points back from Busch in the last transfer position. Gibbs’ driver Christopher Bell is 28 points behind his teammate Busch and Hendrick drivers William Byron (-44) and Alex Bowman (-52) round out the current Playoff field.</p><p>The top five average finishes at the track belong to Elliott (2.7), Blaney (4.7), Bowman (4.7), Logano (7.3), Harvick (7.7) and Byron (7.7). The list includes three of those drivers among the bottom four in the Playoff standings going into the race.</p><p>And Busch, who holds that slim nine-point advantage over Harvick, has an average finish of 33.3. His best career finish at the ROVAL is 30th.</p><p>Harvick’s 21 top-10 finishes through the opening 31 races in 2021 trails only championship leaders Hamlin and Larson, (who have 22 top 10s each). But the 2014 series champion is still looking for his first victory of the season. He’s won at least one race every year since 2010 and career-best nine last season.</p><p>“You dot the “I’s” and cross the “T’s” and really, that’s what it all comes down to," said Harvick, who drives the No. 4 Stewart-Haas Racing Ford. “We’ve lost a lot of races with fast cars and we’ve won some races with slow cars – you grind away and you just keep yourself in there and see where it all shakes out. Sometimes it’s in the car to win and sometimes it’s not, you just never know so you just grind away every lap."</p><p>Even though they are well back in the standings, Byron and Bowman arrive at the Charlotte track feeling optimistic. Byron, who is a Charlotte native, has two top-10 finishes in three ROVAL starts and is trying to advance to the Round of 8 for the first time in his four-year NASCAR Cup Series career.</p><p>Bowman has one of the best average finishes in the field – joining former winners Elliott and Blaney – as the only three drivers with an average finish below 5.0. Bowman may be the Playoff longshot trailing the cutline by 52 points going into the ROVAL race, but he has two top-five and three top-10 results in three races there. His eighth-place finish there last year was good enough to propel him into the Round of 8.</p><p>Three Hendrick drivers, Elliott (62), Larson (52) and the hometown favorite Byron (50) lead all drivers in Laps Led at the ROVAL.</p><p>“The good thing is that I have the same amount of experience there as most of the field since it’s a fairly new track," said Byron, 23, whose rookie NASCAR Cup Series season was also the first year the ROVAL was on the schedule.</p><p>“It’s difficult though because I feel like this is a race where there is always a lot more contact throughout the field and you can’t prepare for that other than to be ready for anything at the moment. We always have fast cars there though so we just need to go there and focus on getting the win. It’s going to be really difficult to worry about points, so a win is really all we’re worried about."</p><p> </p><p><strong>Xfinity Playoffs' Round of 12 to come to a close at Charlotte</strong></p><p>And so the first elimination race of the 2021 NASCAR Xfinity Series Playoffs comes down to a challenging road course with the defending series champion Austin Cindric back atop the standings and a pair of talented first cousins – Harrison and Jeb Burton - straddling the Playoff cutline.</p><p>The first two postseason Round of 12 races have been won by non-Playoff drivers, but there’s a good case to be made that unusual trend will not continue Saturday at the Charlotte Motor Speedway Road Course (ROVAL).</p><p>Regular Season Champion A.J. Allmendinger is the two-time defending winner of Saturday’s Drive For The Cure 250 presented by Blue Cross Blue Shield of North Carolina (3 p.m. ET on NBC, PRN and SiriusXM NASCAR Radio) and after a rare “early exit” and subsequent 39th-place finish at Talladega (Ala.) Superspeedway last weekend, he’s ready to finalize his move to the next round of Playoff competition with a third straight win at his forte of venues.</p><p>Allmendinger, 39, driver of the No. 16 Kaulig Racing Chevrolet edged Noah Gragson by .446-seconds to win the 2020 version of the ROVAL race, but wasn’t competing for the championship a year ago. This weekend, there’s a lot more on the line for the five-time road course winner.</p><p>Allmendinger is really the only one in the series that has truly mastered the 2.280-mile course that incorporates both the speedway turns and an infield road course. The former NASCAR Cup Series and IndyCar driver certainly brings a strong skillset when it comes to left-and-right hand turns – already earning a win at Mid-Ohio, and runner-up finishes at Austin, Watkins Glen, N.Y. and Indianapolis this season. He was fourth at Elkhart Lake, Wisc.</p><p>The Team Penske driver Cindric, another five-time road course race winner, has a pair of third-place finishes and one sixth-place finish in his three Charlotte tries – leading only 13 laps in total (none in his sixth-place finish in 2020). This year, however, he’s finished top-three in three of the six previous road course events, with a victory at Indianapolis, a runner-up at Daytona RC and a third-place at Watkins Glen, N.Y.</p><p>Justin Allgaier, who drives the No. 7 JR Motorsports Chevrolet, is currently ranked second in the championship, 22 points behind Cindric. His best finish in three Charlotte tries is fourth (2019) and he’s never led a lap there.</p><p>Daniel Hemric, driver of the No. 18 Joe Gibbs Racing Toyota, is third in the championship with a pair of top five in the opening round of Playoff competition. His best work in two ROVAL Xfinity Series starts is third in 2020.</p><p>Last year’s ROVAL runner-up Gragson brings a legitimately optimistic outlook to the challenging Charlotte track. The driver of the No. 9 JR Motorsports Chevrolet has had top-10 runs in the last three road courses on the schedule, with a best of fifth at Indianapolis. In two ROVAL starts he has finished fifth (2019) and second (2020).</p><p>Easily the most dramatic aspect of this week’s race will be who transfers into the next round of the championship Playoffs. And after 29 races, the Burton family has found itself right in the middle of the who’s-in and who’s out.</p><p>Joe Gibbs Racing driver Harrison Burton, who turns 21 on race day, holds a slim eight-point advantage over his cousin Jeb Burton for the eighth and final Playoff transfer position.</p><p>Harrison Burton has earned five top-10 finishes in six road course races in 2021, but his best finish at the ROVAL in two starts is 13th in 2019. He suffered a mechanical DNF last Fall.</p><p>Jeb Burton, 29, has earned three top-10 finishes on road courses in his first fulltime season in the series, with a best showing of fifth-place in the No. 10 Kaulig Racing Chevrolet at Daytona. This will be his ROVAL debut.</p><p>Just behind Jeb Burton in the standings is Myatt Snider, 26, who sits 24 points out and reiterated last week at Talladega that he will need to win at Charlotte this week to move on. Snider, who spent time competing on road courses in the NASCAR Whelen Euro Series, has two Xfinity Series road course top 10s in his young career. A seventh-place at Indy this summer is his best.</p><p>The longshot this weekend is Jeremy Clements, who sits 12th out of the 12 Playoff drivers - 48 points below Harrison Burton on the cutoff. However, Clements is one of only four Xfinity Playoff drivers with a road course trophy at home. He scored a dramatic “underdog” win at Elkhart Lake, Wisc. in 2017.</p></div><div class="clr"></div><div class="itemToolbarContent"><div class="itemRatingBlock"> <span>Rate this item</span> <div class="itemRatingForm"><ul class="itemRatingList"> <li class="itemCurrentRating" id="itemCurrentRating65513" style="width:0%;"></li> <li><a ondragstart="return false;" href="#" data-id="65513" title="1 star out of 5" class="one-star">1</a></li> <li><a ondragstart="return false;" href="#" data-id="65513" title="2 stars out of 5" class="two-stars">2</a></li> <li><a ondragstart="return false;" href="#" data-id="65513" title="3 stars out of 5" class="three-stars">3</a></li> <li><a ondragstart="return false;" href="#" data-id="65513" title="4 stars out of 5" class="four-stars">4</a></li> <li><a ondragstart="return false;" href="#" data-id="65513" title="5 stars out of 5" class="five-stars">5</a></li> </ul><div id="itemRatingLog65513" class="itemRatingLog">(0 votes)</div><div class="clr"></div></div><div class="clr"></div></div><div class="itemToolbar float-right"><ul> <li> <span class="itemTextResizerTitle">font size</span> <a ondragstart="return false;" href="#" id="fontDecrease"> <span>decrease font size</span> </a> <a ondragstart="return false;" href="#" id="fontIncrease"> <span>increase font size</span> </a> </li> <li> <a ondragstart="return false;" class="itemPrintLink" rel="nofollow" href="/index.php/news/nascar-cup-series-news/65513-weekend-preview-charlotte-motor-speedway-road-course?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;"> <span>Print</span> </a> </li> <li> <a ondragstart="return false;" class="itemEmailLink" rel="nofollow" href="/index.php/component/mailto/?tmpl=component&amp;template=ts_newslinen&amp;link=930cf1ebb2b73df5eda5be0e7fb7fbe5bb2c94cb" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;"> <span>Email</span> </a> </li> </ul><div class="clr"></div></div></div><div class="itemContentFooter"><div class="clr"></div></div><div class="clr"></div></div><div class="itemSocialSharing"><div class="itemTwitterButton"> <a ondragstart="return false;" href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="">Tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','twitter-wjs');</script> </div><div class="itemFacebookButton"><div id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script><div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div></div><div class="clr"></div></div><div class="itemLinks"><div class="clr"></div></div><div class="itemNavigation"> <a ondragstart="return false;" class="itemPrevious" href="/index.php/news/nascar-cup-series-news/65510-ben-kennedy-s-evolving-leadership-role-at-nascar">&laquo; Ben Kennedy's evolving leadership role at NASCAR</a> <a ondragstart="return false;" class="itemNext" href="/index.php/news/nascar-cup-series-news/65514-daniel-suarez-trackhouse-racing-charlotte-advance">Daniel Suárez Trackhouse Racing Charlotte Advance &raquo;</a> </div><div class="itemAuthorBlock"> <img ondragstart="return false;" class="itemAuthorAvatar jch-lazyload" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/users/13.png" alt="Speedway Digest Staff" /><noscript><img ondragstart="return false;" class="itemAuthorAvatar" src="/media/k2/users/13.png" alt="Speedway Digest Staff" /></noscript><div class="itemAuthorDetails"><h3 class="itemAuthorName"> <a ondragstart="return false;" rel="author" href="/index.php/news/nascar-cup-series-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </h3><p><p>Follow us on Twitter <a ondragstart="return false;" href="https://www.twitter.com/speedwaydigest">@SpeedwayDigest</a></p></p><div class="clr"></div><div class="clr"></div></div><div class="clr"></div></div><div class="itemAuthorLatest"><h3>Latest from Speedway Digest Staff</h3><ul> <li class="even"> <a ondragstart="return false;" href="/index.php/news/racing-news/65519-banking-on-batman-peter-britten-powers-to-1-000-sri-performance-pole-award-in-super-dirtcar-series-qualifying-at-oswego">BANKING ON BATMAN: Peter Britten Powers to $1,000 SRI Performance Pole Award in Super DIRTcar Series Qualifying at Oswego</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/xfinity-series-news/65518-monster-energy-racing-riley-herbst-charlotte-roval-nxs-advance">Monster Energy Racing: Riley Herbst Charlotte Roval NXS Advance</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/racing-news/65517-back-to-night-one-viroc-to-be-contested-during-2022-chili-bowl-opener">Back To Night One! VIROC To Be Contested During 2022 Chili Bowl Opener</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/speedway-news/65516-nashville-superspeedway-honored-at-nascar-s-2021-drive-for-diversity-awards">Nashville Superspeedway honored at NASCAR’s 2021 Drive for Diversity Awards</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/racing-news/65515-billy-dunn-claims-sri-performance-pole-award-for-napa-super-dirt-week-salute-to-the-troops-150">Billy Dunn claims SRI Performance Pole Award for NAPA Super DIRT Week Salute to the Troops 150</a> </li> </ul><div class="clr"></div></div><div class="clr"></div><div class="itemBackToTop"> <a ondragstart="return false;" class="k2Anchor" href="/index.php/news/nascar-cup-series-news/65513-weekend-preview-charlotte-motor-speedway-road-course#startOfPageId65513"> back to top </a> </div><div class="clr"></div></div></div></main><aside id="sp-right" class="col-lg-4 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div></div></aside></div></div></div></section><footer id="sp-footer" class="ts-footer"><div class="row"><div id="sp-footer1" class="col-lg-6 "><div class="sp-column text-center"><span class="sp-copyright">Copyright © 2010 - 2021 STS Motorsports Inc. All Rights Reserved.</span></div></div><div id="sp-footer2" class="col-lg-6 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><ul class="menu nav-pills"> <li class="item-1557"><a ondragstart="return false;" href="/index.php/advertise">Advertise</a></li><li class="item-1559"><a ondragstart="return false;" href="/index.php/privacy-policy">Privacy Policy</a></li><li class="item-1621"><a ondragstart="return false;" href="/index.php/sitemap">Sitemap</a></li><li class="item-1558"><a ondragstart="return false;" href="/index.php/sd-staff">SD Staff</a></li><li class="item-1576"><a ondragstart="return false;" href="/index.php/writer-login">Writer Login</a></li></ul></div></div></div></div></div></footer></div></div><div class="offcanvas-overlay"></div><div class="offcanvas-menu"> <a ondragstart="return false;" href="#" class="close-offcanvas"><span class="fa fa-remove"></span></a> <div class="offcanvas-inner"><div class="sp-module "><div class="sp-module-content"><ul class="menu"> <li class="item-241 default"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="item-186 active menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/news">News<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-205 current active"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="item-188"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="item-1922"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="item-190"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="item-207"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="item-2153"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="item-1876"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></li><li class="item-197 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-198"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="item-199"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="item-200"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="item-202"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></li><li class="item-208 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-209"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="item-210"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="item-211"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></li><li class="item-204 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-235"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="item-236"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="item-237"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="item-1596"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></li><li class="item-606"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></div></div></div></div> <a ondragstart="return false;" href="#" class="sp-scroll-up" aria-label="Scroll Up"><span class="fa fa-chevron-up" aria-hidden="true"></span></a> <amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-auto-format="rspv" data-full-width=""><div overflow=""></div></amp-ad><div id="openModal" class="modalDialog"><div> <a ondragstart="return false;" href="#close" title="Close" id="close" class="close">X</a> <h2>No right click</h2><p>Please link the article. </p></div></div> <script type="text/javascript">disableSelection(document.body)</script> </body> </html>